CVE-2022-38080 exceedone/exment and exceedone/laravel-admin Cross-site Scripting vulnerability
Remote authenticated attackers can inject arbitrary scripts via reflected XSS in Exment, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-38080?
CVE-2022-38080 is a medium-severity cross-site scripting vulnerability in Kajitori Co.,Ltd Exment, published on 24 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Reflected cross-site scripting vulnerability in Exment ((PHP8) exceedone/exment v5.0.2 and earlier and exceedone/laravel-admin v3.0.0 and earlier, (PHP7) exceedone/exment v4.4.2 and earlier and exceedone/laravel-admin v2.2.2 and earlier) allows a remote authenticated attacker to inject an arbitrary script.
Weakness: CWE-79
Which versions are affected by CVE-2022-38080?
8 open source packages ship an affected version, including exceedone/exment and exceedone/laravel-admin. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
exceedone/exment Packagist | All versions | 4.4.3 |
exceedone/exment Packagist | All versions | 4.4.3 |
exceedone/exment Packagist | From 5.0.0 | 5.0.3 |
exceedone/exment Packagist | From 5.0.0 | 5.0.3 |
exceedone/laravel-admin Packagist | All versions | 2.2.3 |
exceedone/laravel-admin Packagist | All versions | 2.2.3 |
2 more packages
exceedone/laravel-admin Packagist | From 3.0.0 | 3.0.1 |
exceedone/laravel-admin Packagist | From 3.0.0 | 3.0.1 |
Products include Exceedone Exment, Exceedone Laravel-Admin.
How do I fix CVE-2022-38080?
Upgrade exceedone/exment to a fixed version for your release line: 4.4.3 or 5.0.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-38080 being exploited?
There is no known exploitation of CVE-2022-38080 in the wild and no public exploit code.
Other vulnerabilities in Kajitori Co.,Ltd Exment
Sources
Also known as GHSA-8629-83m5-rj75.