{"answers":{"affected":"8 open source packages ship an affected version, including exceedone/exment and exceedone/laravel-admin. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-38080 in the wild and no public exploit code.","fix":"Upgrade exceedone/exment to a fixed version for your release line: 4.4.3 or 5.0.3.","what":"CVE-2022-38080 is a medium-severity cross-site scripting vulnerability in Kajitori Co.,Ltd Exment, published on 24 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-38080 and fix it if it is affected.\n\nWhat it is: CVE-2022-38080 is a medium-severity cross-site scripting vulnerability in Kajitori Co.,Ltd Exment, published on 24 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-38080 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- exceedone/exment (Packagist): affected all versions; fixed in 4.4.3\n- exceedone/exment (Packagist): affected all versions; fixed in 4.4.3\n- exceedone/exment (Packagist): affected from 5.0.0; fixed in 5.0.3\n- exceedone/exment (Packagist): affected from 5.0.0; fixed in 5.0.3\n- exceedone/laravel-admin (Packagist): affected all versions; fixed in 2.2.3\n- exceedone/laravel-admin (Packagist): affected all versions; fixed in 2.2.3\n- exceedone/laravel-admin (Packagist): affected from 3.0.0; fixed in 3.0.1\n- exceedone/laravel-admin (Packagist): affected from 3.0.0; fixed in 3.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-38080/ (Markdown: https://insights.sbomify.com/CVE-2022-38080/index.md)","id":"CVE-2022-38080","markdown":"https://insights.sbomify.com/CVE-2022-38080/index.md","name":"CVE-2022-38080","record":{"aliases":["GHSA-8629-83m5-rj75"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Exment web application","requires_auth":"low_privilege","summary":"Remote authenticated attackers can inject arbitrary scripts via reflected XSS in Exment, potentially leading to code execution or account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"exment","vendor":"exceedone"},{"product":"laravel-admin","vendor":"exceedone"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Reflected cross-site scripting vulnerability in Exment ((PHP8) exceedone/exment v5.0.2 and earlier and exceedone/laravel-admin v3.0.0 and earlier, (PHP7) exceedone/exment v4.4.2 and earlier and exceedone/laravel-admin v2.2.2 and earlier) allows a remote authenticated attacker to inject an arbitrary script.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"exceedone/exment and exceedone/laravel-admin Cross-site Scripting vulnerability","id":"CVE-2022-38080","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":8,"n_references":3,"next":{"headline":"Auth bypass in OpenHarmony","id":"CVE-2022-38081"},"packages":[{"ecosystem":"Packagist","fixed":["4.4.3"],"introduced":["0"],"last_affected":[],"package":"exceedone/exment","purl":null,"source":"GHSA-8629-83m5-rj75"},{"ecosystem":"Packagist","fixed":["4.4.3"],"introduced":["0"],"last_affected":[],"package":"exceedone/exment","purl":"pkg:composer/exceedone/exment","source":"GHSA-8629-83m5-rj75"},{"ecosystem":"Packagist","fixed":["5.0.3"],"introduced":["5.0.0"],"last_affected":[],"package":"exceedone/exment","purl":null,"source":"GHSA-8629-83m5-rj75"},{"ecosystem":"Packagist","fixed":["5.0.3"],"introduced":["5.0.0"],"last_affected":[],"package":"exceedone/exment","purl":"pkg:composer/exceedone/exment","source":"GHSA-8629-83m5-rj75"},{"ecosystem":"Packagist","fixed":["2.2.3"],"introduced":["0"],"last_affected":[],"package":"exceedone/laravel-admin","purl":null,"source":"GHSA-8629-83m5-rj75"},{"ecosystem":"Packagist","fixed":["2.2.3"],"introduced":["0"],"last_affected":[],"package":"exceedone/laravel-admin","purl":"pkg:composer/exceedone/laravel-admin","source":"GHSA-8629-83m5-rj75"},{"ecosystem":"Packagist","fixed":["3.0.1"],"introduced":["3.0.0"],"last_affected":[],"package":"exceedone/laravel-admin","purl":null,"source":"GHSA-8629-83m5-rj75"},{"ecosystem":"Packagist","fixed":["3.0.1"],"introduced":["3.0.0"],"last_affected":[],"package":"exceedone/laravel-admin","purl":"pkg:composer/exceedone/laravel-admin","source":"GHSA-8629-83m5-rj75"}],"prev":{"headline":"WordPress Backup Scheduler plugin \u003c= 1.5.13 - Cross-Site Request Forgery (CSRF) vulnerability","id":"CVE-2022-38079"},"products":["Exment"],"published":"2022-08-24","related":[{"cvss_score":8.8,"headline":"exceedone/exment and exceedone/laravel-admin SQL Injection vulnerability","id":"CVE-2022-37333","kev_date_added":null,"published":"2022-08-24"},{"cvss_score":5.4,"headline":"Cross-site scripting in Exment","id":"CVE-2024-47793","kev_date_added":null,"published":"2024-10-18"},{"cvss_score":5.4,"headline":"Cross-site scripting in Exment","id":"CVE-2022-38089","kev_date_added":null,"published":"2022-08-24"},{"cvss_score":5.4,"headline":"Cross-site scripting in Exment","id":"CVE-2020-5619","kev_date_added":null,"published":"2020-08-25"},{"cvss_score":5.4,"headline":"Cross-site scripting in Exment","id":"CVE-2020-5620","kev_date_added":null,"published":"2020-08-25"},{"cvss_score":3.8,"headline":"Missing authorization in Exment","id":"CVE-2024-46897","kev_date_added":null,"published":"2024-10-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Kajitori Co.,Ltd"]},"summary":"Remote authenticated attackers can inject arbitrary scripts via reflected XSS in Exment, potentially leading to code execution or account takeover.","url":"https://insights.sbomify.com/CVE-2022-38080/"}