{"answers":{"affected":"2 open source packages ship an affected version, including silverstripe/versioned-admin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-38145 in the wild and no public exploit code.","fix":"Upgrade silverstripe/versioned-admin to 1.11.1 or later.","what":"CVE-2022-38145 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-38145 and fix it if it is affected.\n\nWhat it is: CVE-2022-38145 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-38145 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- silverstripe/versioned-admin (Packagist): affected from 1.0.0; fixed in 1.11.1\n- silverstripe/versioned-admin (Packagist): affected from 1.0.0; fixed in 1.11.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-38145/ (Markdown: https://insights.sbomify.com/CVE-2022-38145/index.md)","id":"CVE-2022-38145","markdown":"https://insights.sbomify.com/CVE-2022-38145/index.md","name":"CVE-2022-38145","record":{"aliases":["GHSA-66jf-xm2m-7m8r"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Silverstripe CMS","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary JavaScript in the versioned history compare view by injecting payloads into page meta descriptions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"framework","vendor":"silverstripe"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Silverstripe silverstripe/framework through 4.11 allows XSS (issue 1 of 3) via remote attackers adding a Javascript payload to a page's meta description and get it executed in the versioned history compare view.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS in Compare Mode","id":"CVE-2022-38145","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"URL XSS vulnerability due to outdated jquery in CMS","id":"CVE-2022-38146"},"packages":[{"ecosystem":"Packagist","fixed":["1.11.1"],"introduced":["1.0.0"],"last_affected":[],"package":"silverstripe/versioned-admin","purl":null,"source":"GHSA-66jf-xm2m-7m8r"},{"ecosystem":"Packagist","fixed":["1.11.1"],"introduced":["1.0.0"],"last_affected":[],"package":"silverstripe/versioned-admin","purl":"pkg:composer/silverstripe/versioned-admin","source":"GHSA-66jf-xm2m-7m8r"}],"prev":{"headline":"WordPress wpForo Forum plugin \u003c= 2.0.5 - Cross-Site Request Forgery (CSRF) vulnerability","id":"CVE-2022-38144"},"products":["n/a"],"published":"2022-11-23","related":[{"cvss_score":8.8,"headline":"Blind SQL Injection via GridFieldSortableHeader","id":"CVE-2022-38148","kev_date_added":null,"published":"2022-11-21"},{"cvss_score":6.1,"headline":"Reflected XSS in querystring parameters","id":"CVE-2022-38462","kev_date_added":null,"published":"2022-11-22"},{"cvss_score":5.4,"headline":"Silverstripe Framework has a XSS vulnerability in HTML editor","id":"CVE-2025-30148","kev_date_added":null,"published":"2025-04-10"},{"cvss_score":5.4,"headline":"Cross-site Scripting in form messages in silverstripe framework","id":"CVE-2024-53277","kev_date_added":null,"published":"2025-01-14"},{"cvss_score":5.4,"headline":"Cross-site Scripting vulnerability with encoded payload in silverstripe/framework","id":"CVE-2024-32981","kev_date_added":null,"published":"2024-07-17"},{"cvss_score":5.4,"headline":"Silverstripe Framework has open redirect vulnerability on CMSSecurity relogin screen","id":"CVE-2023-22729","kev_date_added":null,"published":"2023-04-26"},{"cvss_score":5.4,"headline":"Stored XSS using HTMLEditor","id":"CVE-2022-37429","kev_date_added":null,"published":"2022-11-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-25","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary JavaScript in the versioned history compare view by injecting payloads into page meta descriptions.","url":"https://insights.sbomify.com/CVE-2022-38145/"}