CVE-2022-3818 Denial of service in GitLab

Medium 5.3 Published Updated

An attacker can cause performance issues and potential denial of service on GitLab instances by exploiting uncontrolled resource consumption during URL parsing.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-3818?

CVE-2022-3818 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 9 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An uncontrolled resource consumption issue when parsing URLs in GitLab CE/EE affecting all versions prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2 allows an attacker to cause performance issues and potentially a denial of service on the GitLab instance.

Weakness: CWE-400

Which versions are affected by CVE-2022-3818?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions15.3.5, 15.4.4, 15.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-3818?

Upgrade gitlab to a fixed version for your release line: 15.3.5, 15.4.4 or 15.5.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-3818 being exploited?

There is no known exploitation of CVE-2022-3818 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-3818, GHSA-6q9r-jfhj-643w, UBUNTU-CVE-2022-3818.

Is CVE-2022-3818 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free