CVE-2022-3820 Auth bypass in GitLab

Medium 6.5 Published Updated

Attackers with valid Deploy Tokens can bypass IP restrictions on Package Registries to access resources from unauthorized locations.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-3820?

CVE-2022-3820 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 24 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2. GitLab was not performing correct authentication with some Package Registries when IP address restrictions were configured, allowing an attacker already in possession of a valid Deploy Token to misuse it from any location.

Weakness: CWE-290

Which versions are affected by CVE-2022-3820?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.4.015.4.6, 15.5.5, 15.6.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-3820?

Upgrade gitlab to a fixed version for your release line: 15.4.6, 15.5.5 or 15.6.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2022-3820 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3820 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-3820, GHSA-jc5p-hfq2-7mfm, UBUNTU-CVE-2022-3820.

Is CVE-2022-3820 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free