# CVE-2022-38298: Server-side request forgery in n/a

> Authenticated attackers can exploit SSRF in Appsmith to access AWS internal metadata endpoints, potentially exposing sensitive cloud credentials.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-appsmith-2022-38298, GHSA-8fww-hhqw-438g

## What is CVE-2022-38298?

CVE-2022-38298 is a high-severity server-side request forgery vulnerability in n/a, published on 12 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Appsmith v1.7.11 was discovered to allow attackers to execute an authenticated Server-Side Request Forgery (SSRF) via redirecting incoming requests to the AWS internal metadata endpoint.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-38298?

1 open source package ship an affected version, including appsmith. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `appsmith` | Bitnami | From 1.7.11 | 1.7.12 |

Products: Appsmith Appsmith.

## How do I fix CVE-2022-38298?

Upgrade appsmith to 1.7.12 or later.

## Is CVE-2022-38298 being exploited?

There is no known exploitation of CVE-2022-38298 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-55454](https://insights.sbomify.com/CVE-2026-55454/): Appsmith: Caddy admin API exposed without authentication (critical 9.9)
- [CVE-2024-55964](https://insights.sbomify.com/CVE-2024-55964/): Code injection in n/a (critical 9.8)
- [CVE-2026-22794](https://insights.sbomify.com/CVE-2026-22794/): Account Takeover Vulnerability in Appsmith (critical 9.7)
- [CVE-2026-24042](https://insights.sbomify.com/CVE-2026-24042/): Appsmith public apps can execute unpublished actions (viewMode confusion) (critical 9.4)
- [CVE-2026-30862](https://insights.sbomify.com/CVE-2026-30862/): Critical Stored XSS & Privilege Escalation in Appsmith (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-38298 and fix it if it is affected.

What it is: CVE-2022-38298 is a high-severity server-side request forgery vulnerability in n/a, published on 12 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-38298 in the wild and no public exploit code.

Affected packages and fixed versions:
- appsmith (Bitnami): affected from 1.7.11; fixed in 1.7.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-38298/ (Markdown: https://insights.sbomify.com/CVE-2022-38298/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-38298
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-38298
- OSV: https://osv.dev/vulnerability/CVE-2022-38298

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-38298/
Summaries are generated and may contain mistakes; the official description above is the record.
