CVE-2022-38362 Docker Provider <3.0 RCE vulnerability in example dag

High 8.8 Published Updated

An authenticated attacker can execute arbitrary code on the Airflow worker host via a vulnerable example DAG in the Docker provider.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-38362?

CVE-2022-38362 is a high-severity code injection vulnerability in Apache Airflow, published on 16 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Airflow Docker's Provider prior to 3.0.0 shipped with an example DAG that was vulnerable to (authenticated) remote code exploit of code on the Airflow worker host.

Which versions are affected by CVE-2022-38362?

3 open source packages ship an affected version, including apache-airflow-providers-docker. It affects 1 product.

PackageAffectedFixed in
apache-airflow-providers-docker PyPIAll versions3.0.0
apache-airflow-providers-docker PyPIAll versions3.0.0
apache-airflow-providers-docker PyPIAll versions3.0.0

Products include Apache Apache-Airflow-Providers-Docker.

How do I fix CVE-2022-38362?

Upgrade apache-airflow-providers-docker to 3.0.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2022-38362 being exploited?

There is no known exploitation of CVE-2022-38362 in the wild and no public exploit code.

Sources

Also known as GHSA-746v-hfh2-xphm, PYSEC-2026-773.

Is CVE-2022-38362 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free