# CVE-2022-38362: Docker Provider <3.0 RCE vulnerability in example dag

> An authenticated attacker can execute arbitrary code on the Airflow worker host via a vulnerable example DAG in the Docker provider.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-746v-hfh2-xphm, PYSEC-2026-773

## What is CVE-2022-38362?

CVE-2022-38362 is a high-severity code injection vulnerability in Apache Airflow, published on 16 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow Docker's Provider prior to 3.0.0 shipped with an example DAG that was vulnerable to (authenticated) remote code exploit of code on the Airflow worker host.

## Which versions are affected by CVE-2022-38362?

3 open source packages ship an affected version, including apache-airflow-providers-docker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-docker` | PyPI | All versions | 3.0.0 |
| `apache-airflow-providers-docker` | PyPI | All versions | 3.0.0 |
| `apache-airflow-providers-docker` | PyPI | All versions | 3.0.0 |

Products: Apache Apache-Airflow-Providers-Docker.

## How do I fix CVE-2022-38362?

Upgrade apache-airflow-providers-docker to 3.0.0 or later.

## Is CVE-2022-38362 being exploited?

There is no known exploitation of CVE-2022-38362 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-38362 and fix it if it is affected.

What it is: CVE-2022-38362 is a high-severity code injection vulnerability in Apache Airflow, published on 16 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-38362 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-docker (PyPI): affected all versions; fixed in 3.0.0
- apache-airflow-providers-docker (PyPI): affected all versions; fixed in 3.0.0
- apache-airflow-providers-docker (PyPI): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-38362/ (Markdown: https://insights.sbomify.com/CVE-2022-38362/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-38362
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-38362
- OSV: https://osv.dev/vulnerability/CVE-2022-38362

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-38362/
Summaries are generated and may contain mistakes; the official description above is the record.
