{"answers":{"affected":"2 open source packages ship an affected version, including valine. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-38545 in the wild and no public exploit code.","fix":"Upgrade valine to 1.5.0 or later.","what":"CVE-2022-38545 is a critical cross-site scripting vulnerability in n/a, published on 19 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-38545 and fix it if it is affected.\n\nWhat it is: CVE-2022-38545 is a critical cross-site scripting vulnerability in n/a, published on 19 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-38545 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- valine (npm): affected all versions; fixed in 1.5.0\n- valine (npm): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-38545/ (Markdown: https://insights.sbomify.com/CVE-2022-38545/index.md)","id":"CVE-2022-38545","markdown":"https://insights.sbomify.com/CVE-2022-38545/index.md","name":"CVE-2022-38545","record":{"aliases":["GHSA-mcvg-g9wx-v5vx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Valine comment system","requires_auth":"none","summary":"Attackers can execute arbitrary code via crafted POST requests in the Valine comment system, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"valine","vendor":"valine.js"}],"cvss":{"score":9.6,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Valine v1.4.18 was discovered to contain a remote code execution (RCE) vulnerability which allows attackers to execute arbitrary code via a crafted POST request.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Valine code injection vulnerability","id":"CVE-2022-38545","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Misconfiguration in NBG7510 firmware","id":"CVE-2022-38546"},"packages":[{"ecosystem":"npm","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"valine","purl":null,"source":"GHSA-mcvg-g9wx-v5vx"},{"ecosystem":"npm","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"valine","purl":"pkg:npm/valine","source":"GHSA-mcvg-g9wx-v5vx"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2022-38542"},"products":["n/a"],"published":"2022-09-19","related":[{"cvss_score":6.1,"headline":"Valine HTML Injection","id":"CVE-2018-19289","kev_date_added":null,"published":"2018-11-15"},{"cvss_score":5.4,"headline":"Cross site scripting in valine","id":"CVE-2020-28847","kev_date_added":null,"published":"2022-04-05"},{"cvss_score":5.3,"headline":"Denial of service in Valine","id":"CVE-2021-34801","kev_date_added":null,"published":"2021-06-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via crafted POST requests in the Valine comment system, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2022-38545/"}