# CVE-2022-38577: Privilege escalation in n/a

> Attackers can escalate normal users to Administrators due to insecure permissions in the user profile page of ProcessMaker.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2022
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-processmaker-2022-38577, GHSA-gc28-55g9-f45f

## What is CVE-2022-38577?

CVE-2022-38577 is a high-severity vulnerability in n/a, published on 19 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ProcessMaker before v3.5.4 was discovered to contain insecure permissions in the user profile page. This vulnerability allows attackers to escalate normal users to Administrators.

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2022-38577?

1 open source package ship an affected version, including processmaker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `processmaker` | Bitnami | All versions | 3.5.4 |

Products: Processmaker Processmaker.

## How do I fix CVE-2022-38577?

Upgrade processmaker to 3.5.4 or later.

## Is CVE-2022-38577 being exploited?

There is no known exploitation of CVE-2022-38577 in the wild and no public exploit code.

Public exploit code:

- ProcessMaker before v3.5.4 was discovered to contain insecure permissions in the user profile page. This vulnerability allows attackers to escalate normal users to Administrators. (github_poc): https://github.com/sornram9254/CVE-2022-38577-Processmaker

## Other vulnerabilities in n/a

- [CVE-2016-9045](https://insights.sbomify.com/CVE-2016-9045/): Deserialization in ProcessMaker Enterprise (high 8.8)
- [CVE-2016-9048](https://insights.sbomify.com/CVE-2016-9048/): SQL injection in ProcessMaker Enterprise (high 7.4)
- [CVE-2020-13526](https://insights.sbomify.com/CVE-2020-13526/): SQL injection in ProcessMaker (medium 6.4)
- [CVE-2020-13525](https://insights.sbomify.com/CVE-2020-13525/): SQL injection in ProcessMaker (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-38577 and fix it if it is affected.

What it is: CVE-2022-38577 is a high-severity vulnerability in n/a, published on 19 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-38577 in the wild and no public exploit code.

Affected packages and fixed versions:
- processmaker (Bitnami): affected all versions; fixed in 3.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-38577/ (Markdown: https://insights.sbomify.com/CVE-2022-38577/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-38577
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-38577
- OSV: https://osv.dev/vulnerability/CVE-2022-38577

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-38577/
Summaries are generated and may contain mistakes; the official description above is the record.
