# CVE-2022-38649: Apache Airflow Pinot provider allowed Command Injection

> Attackers can execute arbitrary OS commands in the task execution context via the Apache Airflow Pinot Provider without needing write access to DAG files.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Nov 2022
- **Updated:** 29 Apr 2025
- **Also known as:** BIT-airflow-2022-38649, GHSA-7wqf-h36w-47mc, PYSEC-2026-267

## What is CVE-2022-38649?

CVE-2022-38649 is a critical command injection vulnerability in Apache Airflow, published on 22 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Pinot Provider, Apache Airflow allows an attacker to control commands executed in the task execution context, without write access to DAG files. This issue affects Apache Airflow Pinot Provider versions prior to 4.0.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case Apache Airflow Pinot Provider is installed (Apache Airflow Pinot Provider 4.0.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the Pinot Provider version 4.0.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-38649?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.3.0 |
| `apache-airflow` | PyPI | All versions | 2.3.0 |
| `apache-airflow` | PyPI | All versions | 2.3.0 |
| `airflow` | Bitnami | All versions | 2.3.0 |

Products: Apache Airflow, Apache Apache-Airflow-Providers-Apache-Pinot.

## How do I fix CVE-2022-38649?

Upgrade apache-airflow to 2.3.0 or later.

## Is CVE-2022-38649 being exploited?

There is no known exploitation of CVE-2022-38649 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-38649 and fix it if it is affected.

What it is: CVE-2022-38649 is a critical command injection vulnerability in Apache Airflow, published on 22 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-38649 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.3.0
- apache-airflow (PyPI): affected all versions; fixed in 2.3.0
- apache-airflow (PyPI): affected all versions; fixed in 2.3.0
- airflow (Bitnami): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-38649/ (Markdown: https://insights.sbomify.com/CVE-2022-38649/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-38649
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-38649
- OSV: https://osv.dev/vulnerability/CVE-2022-38649

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-38649/
Summaries are generated and may contain mistakes; the official description above is the record.
