# CVE-2022-3867: Nomad Event Stream Subscriber Using a Token with TTL Receives Updates Until Garbage Collected

> Attackers with short-lived tokens can continue receiving event stream updates after token expiration until garbage collection occurs.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2022
- **Updated:** 1 May 2025
- **Also known as:** GHSA-9fmc-5fq4-5jwh, GO-2022-1106, UBUNTU-CVE-2022-3867

## What is CVE-2022-3867?

CVE-2022-3867 is a low-severity vulnerability in HashiCorp Nomad, published on 10 Nov 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

HashiCorp Nomad and Nomad Enterprise 1.4.0 up to 1.4.1 event stream subscribers using a token with TTL receive updates until token garbage is collected. Fixed in 1.4.2.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2022-3867?

3 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/nomad` | Go | From 1.4.0 | 1.4.2 |
| `github.com/hashicorp/nomad` | Go | From 1.4.0 | 1.4.2 |
| `github.com/hashicorp/nomad` | Go | From 1.4.0 | 1.4.2 |

Products: Hashicorp Nomad.

## How do I fix CVE-2022-3867?

Upgrade github.com/hashicorp/nomad to 1.4.2 or later.

## Is CVE-2022-3867 being exploited?

There is no known exploitation of CVE-2022-3867 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Nomad

- [CVE-2023-1782](https://insights.sbomify.com/CVE-2023-1782/): Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation (critical 10.0)
- [CVE-2022-30324](https://insights.sbomify.com/CVE-2022-30324/): Privilege escalation in Hashicorp Nomad (critical 9.8)
- [CVE-2020-7956](https://insights.sbomify.com/CVE-2020-7956/): Improper Certificate Validation in HashiCorp Nomad (critical 9.8)
- [CVE-2019-12618](https://insights.sbomify.com/CVE-2019-12618/): Hashicorp Nomad Access Control Issues (critical 9.8)
- [CVE-2020-27195](https://insights.sbomify.com/CVE-2020-27195/): Use After Free in HashiCorp Nomad (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3867 and fix it if it is affected.

What it is: CVE-2022-3867 is a low-severity vulnerability in HashiCorp Nomad, published on 10 Nov 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-3867 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/nomad (Go): affected from 1.4.0; fixed in 1.4.2
- github.com/hashicorp/nomad (Go): affected from 1.4.0; fixed in 1.4.2
- github.com/hashicorp/nomad (Go): affected from 1.4.0; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3867/ (Markdown: https://insights.sbomify.com/CVE-2022-3867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3867
- OSV: https://osv.dev/vulnerability/CVE-2022-3867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3867/
Summaries are generated and may contain mistakes; the official description above is the record.
