{"answers":{"affected":"2 open source packages ship an affected version, including io.gravitee.apim:gravitee-api-management. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-38723 in the wild and no public exploit code.","fix":"Upgrade io.gravitee.apim:gravitee-api-management to 3.15.13 or later.","what":"CVE-2022-38723 is a high-severity path traversal vulnerability in n/a, published on 3 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-38723 and fix it if it is affected.\n\nWhat it is: CVE-2022-38723 is a high-severity path traversal vulnerability in n/a, published on 3 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-38723 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.gravitee.apim:gravitee-api-management (Maven): affected all versions; fixed in 3.15.13\n- io.gravitee.apim:gravitee-api-management (Maven): affected all versions; fixed in 3.15.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-38723/ (Markdown: https://insights.sbomify.com/CVE-2022-38723/index.md)","id":"CVE-2022-38723","markdown":"https://insights.sbomify.com/CVE-2022-38723/index.md","name":"CVE-2022-38723","record":{"aliases":["GHSA-vp62-m958-qj8c"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"API Management Platform","requires_auth":"none","summary":"Attackers can exploit path traversal via HTML injection in Gravitee API Management to access unauthorized files or execute code.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"api_management","vendor":"gravitee"}],"cvss":{"score":8.6,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Gravitee API Management before 3.15.13 allows path traversal through HTML injection.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Gravitee API Management contains Path Traversal","id":"CVE-2022-38723","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Silverstripe XSS in shortcodes","id":"CVE-2022-38724"},"packages":[{"ecosystem":"Maven","fixed":["3.15.13"],"introduced":["0"],"last_affected":[],"package":"io.gravitee.apim:gravitee-api-management","purl":null,"source":"GHSA-vp62-m958-qj8c"},{"ecosystem":"Maven","fixed":["3.15.13"],"introduced":["0"],"last_affected":[],"package":"io.gravitee.apim:gravitee-api-management","purl":"pkg:maven/io.gravitee.apim/gravitee-api-management","source":"GHSA-vp62-m958-qj8c"}],"prev":{"headline":"WordPress Motors – Car Dealer \u0026 Classified Ads Plugin \u003c= 1.4.4 is vulnerable to Cross Site Request Forgery (CSRF)","id":"CVE-2022-38716"},"products":["n/a"],"published":"2023-01-03","related":[{"cvss_score":6.1,"headline":"Path Traversal in Gravitee API Management","id":"CVE-2019-25075","kev_date_added":null,"published":"2022-08-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-10","vendors":["n/a"]},"summary":"Attackers can exploit path traversal via HTML injection in Gravitee API Management to access unauthorized files or execute code.","url":"https://insights.sbomify.com/CVE-2022-38723/"}