# CVE-2022-38724: Silverstripe XSS in shortcodes

> Cross-site scripting vulnerability in Silverstripe CMS allows attackers to inject malicious scripts into web pages viewed by other users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Nov 2022
- **Updated:** 29 Apr 2025
- **Also known as:** GHSA-9cx2-hj6m-fv58

## What is CVE-2022-38724?

CVE-2022-38724 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Silverstripe silverstripe/framework through 4.11.0, silverstripe/assets through 1.11.0, and silverstripe/asset-admin through 1.11.0 allow XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-38724?

4 open source packages ship an affected version, including silverstripe/assets and silverstripe/framework. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/assets` | Packagist | From 1.0.0 | 1.11.1 |
| `silverstripe/assets` | Packagist | From 1.0.0 | 1.11.1 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.11.13 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.11.13 |

Products: Silverstripe Asset Admin, Silverstripe Assets, Silverstripe Framework.

## How do I fix CVE-2022-38724?

Upgrade silverstripe/assets to 1.11.1 or later.

## Is CVE-2022-38724 being exploited?

There is no known exploitation of CVE-2022-38724 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-38724 and fix it if it is affected.

What it is: CVE-2022-38724 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-38724 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/assets (Packagist): affected from 1.0.0; fixed in 1.11.1
- silverstripe/assets (Packagist): affected from 1.0.0; fixed in 1.11.1
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.11.13
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.11.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-38724/ (Markdown: https://insights.sbomify.com/CVE-2022-38724/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-38724
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-38724
- OSV: https://osv.dev/vulnerability/CVE-2022-38724

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-38724/
Summaries are generated and may contain mistakes; the official description above is the record.
