{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-38725 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-38725 is a high-severity vulnerability in n/a, published on 23 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-38725 and fix it if it is affected.\n\nWhat it is: CVE-2022-38725 is a high-severity vulnerability in n/a, published on 23 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-38725 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-38725/ (Markdown: https://insights.sbomify.com/CVE-2022-38725/index.md)","id":"CVE-2022-38725","markdown":"https://insights.sbomify.com/CVE-2022-38725/index.md","name":"CVE-2022-38725","record":{"aliases":["ALPINE-CVE-2022-38725","AZL-13205","AZL-35289","DEBIAN-CVE-2022-38725","DLA-3348-1","DSA-5369-1","GHSA-7932-4fc6-pvmc","SUSE-SU-2023:0319-1","UBUNTU-CVE-2022-38725","openSUSE-SU-2023:0040-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"syslog-ng server","requires_auth":"none","summary":"Remote attackers can cause a denial of service in syslog-ng by sending crafted syslog input that triggers an integer overflow in the RFC3164 parser.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"syslog-ng","vendor":"oneidentity"},{"product":"syslog-ng_store_box","vendor":"oneidentity"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"An integer overflow in the RFC3164 parser in One Identity syslog-ng 3.0 through 3.37 allows remote attackers to cause a Denial of Service via crafted syslog input that is mishandled by the tcp or network function. syslog-ng Premium Edition 7.0.30 and syslog-ng Store Box 6.10.0 are also affected.","ecosystems":["SUSE:Linux Enterprise Module for Legacy 12","SUSE:Package Hub 15 SP4","openSUSE:Leap 15.4"],"exploits":{"exploitdb":0,"first_seen":"2024-08-12","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-08-12T17:27:57Z","kind":"github_poc","ref":"https://github.com/wdahlenburg/CVE-2022-38725","stars":0,"title":"Proof of Concept for CVE-2022-38725 against syslog-ng"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2022-38725","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2022"},"n_packages":3,"n_references":7,"next":{"headline":"Race condition in n/a","id":"CVE-2022-38730"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Legacy 12","fixed":["3.6.4-12.11.1"],"introduced":["0"],"last_affected":[],"package":"syslog-ng","purl":"pkg:rpm/suse/syslog-ng\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Legacy%2012","source":"SUSE-SU-2023:0319-1"},{"ecosystem":"SUSE:Package Hub 15 SP4","fixed":["3.35.1-bp154.3.3.1"],"introduced":["0"],"last_affected":[],"package":"syslog-ng","purl":"pkg:rpm/suse/syslog-ng\u0026distro=SUSE%20Package%20Hub%2015%20SP4","source":"openSUSE-SU-2023:0040-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["3.35.1-bp154.3.3.1"],"introduced":["0"],"last_affected":[],"package":"syslog-ng","purl":"pkg:rpm/opensuse/syslog-ng\u0026distro=openSUSE%20Leap%2015.4","source":"openSUSE-SU-2023:0040-1"}],"prev":{"headline":"Silverstripe XSS in shortcodes","id":"CVE-2022-38724"},"products":["n/a"],"published":"2023-01-23","related":[{"cvss_score":9.3,"headline":"Other in n/a","id":"CVE-2008-5110","kev_date_added":null,"published":"2008-11-17"},{"cvss_score":7.7,"headline":"syslog-ng: Local privilege escalation from new to root in %post","id":"CVE-2020-8019","kev_date_added":null,"published":"2020-06-29"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2002-1200","kev_date_added":null,"published":"2004-09-01"},{"cvss_score":6.9,"headline":"Misconfiguration in n/a","id":"CVE-2011-0343","kev_date_added":null,"published":"2011-01-28"},{"cvss_score":4.3,"headline":"Denial of service in n/a","id":"CVE-2011-1951","kev_date_added":null,"published":"2011-07-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-03","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in syslog-ng by sending crafted syslog input that triggers an integer overflow in the RFC3164 parser.","url":"https://insights.sbomify.com/CVE-2022-38725/"}