CVE-2022-38900 decode-uri-component vulnerable to Denial of Service (DoS)
An attacker can cause a denial of service by sending specially crafted input to the decode-uri-component library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-38900?
CVE-2022-38900 is a high-severity denial of service vulnerability in n/a, published on 28 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
decode-uri-component 0.2.0 is vulnerable to Improper Input Validation resulting in DoS.
Weakness: CWE-20
Which versions are affected by CVE-2022-38900?
2 open source packages ship an affected version, including decode-uri-component. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
decode-uri-component npm | All versions | 0.2.1 |
decode-uri-component npm | All versions | 0.2.1 |
Linux distribution packages (6)
pcs AlmaLinux:9 | All versions | 0.11.6-3.el9 |
pcs-snmp AlmaLinux:9 | All versions | 0.11.6-3.el9 |
pcs Red Hat:enterprise_linux:9::highavailability | All versions | 0:0.11.6-3.el9 |
pcs-snmp Red Hat:enterprise_linux:9::highavailability | All versions | 0:0.11.6-3.el9 |
pcs Red Hat:enterprise_linux:9::resilientstorage | All versions | 0:0.11.6-3.el9 |
pcs-snmp Red Hat:enterprise_linux:9::resilientstorage | All versions | 0:0.11.6-3.el9 |
Products include Decode-Uri-Component Project Decode-Uri-Component.
How do I fix CVE-2022-38900?
Upgrade decode-uri-component to 0.2.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-38900 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-38900 exists.
Other vulnerabilities in n/a
Sources
Also known as ALSA-2023:6316, AZL-44976, CLSA-2026-1780620683, GHSA-w573-4hg7-7wgq, RHSA-2023:6316, ROOT-APP-NPM-CVE-2022-38900.