# CVE-2022-38900: decode-uri-component vulnerable to Denial of Service (DoS)

> An attacker can cause a denial of service by sending specially crafted input to the decode-uri-component library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Nov 2022
- **Updated:** 25 Apr 2025
- **Also known as:** ALSA-2023:6316, AZL-44976, CLSA-2026-1780620683, GHSA-w573-4hg7-7wgq, RHSA-2023:6316, ROOT-APP-NPM-CVE-2022-38900

## What is CVE-2022-38900?

CVE-2022-38900 is a high-severity denial of service vulnerability in n/a, published on 28 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

decode-uri-component 0.2.0 is vulnerable to Improper Input Validation resulting in DoS.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-38900?

2 open source packages ship an affected version, including decode-uri-component. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decode-uri-component` | npm | All versions | 0.2.1 |
| `decode-uri-component` | npm | All versions | 0.2.1 |
| `pcs` | AlmaLinux:9 | All versions | 0.11.6-3.el9 |
| `pcs-snmp` | AlmaLinux:9 | All versions | 0.11.6-3.el9 |
| `pcs` | Red Hat:enterprise_linux:9::highavailability | All versions | 0:0.11.6-3.el9 |
| `pcs-snmp` | Red Hat:enterprise_linux:9::highavailability | All versions | 0:0.11.6-3.el9 |
| `pcs` | Red Hat:enterprise_linux:9::resilientstorage | All versions | 0:0.11.6-3.el9 |
| `pcs-snmp` | Red Hat:enterprise_linux:9::resilientstorage | All versions | 0:0.11.6-3.el9 |

Products: Decode-Uri-Component Project Decode-Uri-Component.

## How do I fix CVE-2022-38900?

Upgrade decode-uri-component to 0.2.1 or later.

## Is CVE-2022-38900 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-38900 exists.

## Other vulnerabilities in n/a

- [CVE-2022-38778](https://insights.sbomify.com/CVE-2022-38778/): Denial of service in kibana (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-38900 and fix it if it is affected.

What it is: CVE-2022-38900 is a high-severity denial of service vulnerability in n/a, published on 28 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-38900 exists.

Affected packages and fixed versions:
- decode-uri-component (npm): affected all versions; fixed in 0.2.1
- decode-uri-component (npm): affected all versions; fixed in 0.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-38900/ (Markdown: https://insights.sbomify.com/CVE-2022-38900/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-38900
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-38900
- OSV: https://osv.dev/vulnerability/CVE-2022-38900

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-38900/
Summaries are generated and may contain mistakes; the official description above is the record.
