# CVE-2022-39193: Information disclosure in n/a

> The CheckUser extension for MediaWiki improperly exposes private edit and log performer information to unauthorized users.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jan 2023
- **Updated:** 3 Apr 2025
- **Also known as:** BIT-mediawiki-2022-39193, GHSA-5jq2-gw2c-fg5h

## What is CVE-2022-39193?

CVE-2022-39193 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 20 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the CheckUser extension for MediaWiki through 1.39.x. Various components of this extension can expose information on the performer of edits and logged actions. This information should not allow public viewing: it is supposed to be viewable only by users with suppression rights.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-39193?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | From 1.39.0 | 1.39.2 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2022-39193?

Upgrade mediawiki to 1.39.2 or later.

## Is CVE-2022-39193 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39193 exists.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39193 and fix it if it is affected.

What it is: CVE-2022-39193 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 20 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39193 exists.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected from 1.39.0; fixed in 1.39.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39193/ (Markdown: https://insights.sbomify.com/CVE-2022-39193/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39193
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39193
- OSV: https://osv.dev/vulnerability/CVE-2022-39193

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39193/
Summaries are generated and may contain mistakes; the official description above is the record.
