CVE-2022-39198 Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass
Attackers can execute arbitrary code via deserialization gadgets in Apache Dubbo's Hessian-lite library, requiring an upgrade to secure versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-39198?
CVE-2022-39198 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 18 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.
Weakness: CWE-502
Which versions are affected by CVE-2022-39198?
8 open source packages ship an affected version, including org.apache.dubbo:dubbo and com.alibaba:hessian-lite. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.dubbo:dubbo Maven | From 2.7.0 | 2.7.18 |
org.apache.dubbo:dubbo Maven | From 2.7.0 | 2.7.18 |
org.apache.dubbo:dubbo Maven | From 3.0.0 | 3.0.12 |
org.apache.dubbo:dubbo Maven | From 3.0.0 | 3.0.12 |
org.apache.dubbo:dubbo Maven | From 3.1.0 | 3.1.1 |
org.apache.dubbo:dubbo Maven | From 3.1.0 | 3.1.1 |
2 more packages
com.alibaba:hessian-lite Maven | All versions | 3.2.13 |
com.alibaba:hessian-lite Maven | All versions | 3.2.13 |
Products include Apache Dubbo.
How do I fix CVE-2022-39198?
Upgrade org.apache.dubbo:dubbo to a fixed version for your release line: 2.7.18, 3.0.12 or 3.1.1.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2022-39198 being exploited?
There is no known exploitation of CVE-2022-39198 in the wild and no public exploit code.
Other vulnerabilities in Apache Dubbo
- CVE-2023-29234 Bypass serialize checks in Apache Dubbo
- CVE-2023-46279 Apache Dubbo: Bypass deny serialize list check in Apache Dubbo
- CVE-2021-32824 Regular expression Denial of Service in MooTools
- CVE-2021-43297 Dubbo Hessian cause RCE when parse error
- CVE-2021-36161 Unprotected input value toString cause RCE
Sources
Also known as GHSA-5qwq-g2hx-r6f7.