# CVE-2022-39198: Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass

> Attackers can execute arbitrary code via deserialization gadgets in Apache Dubbo's Hessian-lite library, requiring an upgrade to secure versions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Oct 2022
- **Updated:** 13 May 2025
- **Also known as:** GHSA-5qwq-g2hx-r6f7

## What is CVE-2022-39198?

CVE-2022-39198 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 18 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-39198?

8 open source packages ship an affected version, including org.apache.dubbo:dubbo and com.alibaba:hessian-lite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dubbo:dubbo` | Maven | From 2.7.0 | 2.7.18 |
| `org.apache.dubbo:dubbo` | Maven | From 2.7.0 | 2.7.18 |
| `org.apache.dubbo:dubbo` | Maven | From 3.0.0 | 3.0.12 |
| `org.apache.dubbo:dubbo` | Maven | From 3.0.0 | 3.0.12 |
| `org.apache.dubbo:dubbo` | Maven | From 3.1.0 | 3.1.1 |
| `org.apache.dubbo:dubbo` | Maven | From 3.1.0 | 3.1.1 |
| `com.alibaba:hessian-lite` | Maven | All versions | 3.2.13 |
| `com.alibaba:hessian-lite` | Maven | All versions | 3.2.13 |

Products: Apache Dubbo.

## How do I fix CVE-2022-39198?

Upgrade org.apache.dubbo:dubbo to a fixed version for your release line: 2.7.18, 3.0.12 or 3.1.1.

## Is CVE-2022-39198 being exploited?

There is no known exploitation of CVE-2022-39198 in the wild and no public exploit code.

## Other vulnerabilities in Apache Dubbo

- [CVE-2023-29234](https://insights.sbomify.com/CVE-2023-29234/): Bypass serialize checks in Apache Dubbo (critical 9.8)
- [CVE-2023-46279](https://insights.sbomify.com/CVE-2023-46279/): Apache Dubbo: Bypass deny serialize list check in Apache Dubbo (critical 9.8)
- [CVE-2021-32824](https://insights.sbomify.com/CVE-2021-32824/): Regular expression Denial of Service in MooTools (critical 9.8)
- [CVE-2021-43297](https://insights.sbomify.com/CVE-2021-43297/): Dubbo Hessian cause RCE when parse error (critical 9.8)
- [CVE-2021-36161](https://insights.sbomify.com/CVE-2021-36161/): Unprotected input value toString cause RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39198 and fix it if it is affected.

What it is: CVE-2022-39198 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 18 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39198 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dubbo:dubbo (Maven): affected from 2.7.0; fixed in 2.7.18
- org.apache.dubbo:dubbo (Maven): affected from 2.7.0; fixed in 2.7.18
- org.apache.dubbo:dubbo (Maven): affected from 3.0.0; fixed in 3.0.12
- org.apache.dubbo:dubbo (Maven): affected from 3.0.0; fixed in 3.0.12
- org.apache.dubbo:dubbo (Maven): affected from 3.1.0; fixed in 3.1.1
- org.apache.dubbo:dubbo (Maven): affected from 3.1.0; fixed in 3.1.1
- com.alibaba:hessian-lite (Maven): affected all versions; fixed in 3.2.13
- com.alibaba:hessian-lite (Maven): affected all versions; fixed in 3.2.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39198/ (Markdown: https://insights.sbomify.com/CVE-2022-39198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39198
- OSV: https://osv.dev/vulnerability/CVE-2022-39198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39198/
Summaries are generated and may contain mistakes; the official description above is the record.
