CVE-2022-39201 Data source and plugin proxy endpoints could leak the authentication cookie to some destination plugins

Medium 6.8 Published Updated

Attackers can steal user authentication cookies via data source and plugin proxy endpoints, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-39201?

CVE-2022-39201 is a medium-severity vulnerability in Grafana Grafana, published on 13 Oct 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Grafana is an open source observability and data visualization platform. Starting with version 5.0.0-beta1 and prior to versions 8.5.14 and 9.1.8, Grafana could leak the authentication cookie of users to plugins. The vulnerability impacts data source and plugin proxy endpoints under certain conditions. The destination plugin could receive a user's Grafana authentication cookie. Versions 9.1.8 and 8.5.14 contain a patch for this issue. There are no known workarounds.

Weakness: CWE-200

Which versions are affected by CVE-2022-39201?

6 open source packages ship an affected version, including github.com/grafana/grafana and grafana. It affects 1 product.

PackageAffectedFixed in
github.com/grafana/grafana GoFrom 5.0.0-beta18.5.14
github.com/grafana/grafana GoFrom 5.0.0-beta18.5.14
github.com/grafana/grafana GoFrom 5.0.0-beta1+incompatibleNone
github.com/grafana/grafana GoFrom 9.0.09.1.8
github.com/grafana/grafana GoFrom 9.0.09.1.8
grafana BitnamiFrom 5.0.18.5.14, 9.1.8

Products include Grafana Grafana.

How do I fix CVE-2022-39201?

Upgrade github.com/grafana/grafana to a fixed version for your release line: 8.5.14 or 9.1.8.

Is CVE-2022-39201 being exploited?

There is no known exploitation of CVE-2022-39201 in the wild and no public exploit code.

All Grafana Grafana vulnerabilities

Sources

Also known as BIT-grafana-2022-39201, GHSA-x744-mm8v-vpgr, GO-2024-2858, MINI-24r7-3qcr-5vc4, MINI-27hm-9h7m-hgw4, MINI-3xr8-q5x6-hc2m and 15 more.

Is CVE-2022-39201 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free