# CVE-2022-39201: Data source and plugin proxy endpoints could leak the authentication cookie to some destination plugins

> Attackers can steal user authentication cookies via data source and plugin proxy endpoints, potentially leading to account takeover.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-grafana-2022-39201, GHSA-x744-mm8v-vpgr, GO-2024-2858, MINI-24r7-3qcr-5vc4, MINI-27hm-9h7m-hgw4, MINI-3xr8-q5x6-hc2m, MINI-55vx-9gj9-gvxg, MINI-5qvm-jrw8-fw47, MINI-67q3-4qx4-fm4j, MINI-72m6-c938-x9vv, MINI-c994-4382-3hjx, MINI-cf68-j4gp-qpxc, MINI-f2c7-2gwv-2f8m, MINI-g5g5-852m-j46f, MINI-px24-gjcg-5wg9, MINI-q75x-9qw9-h84x, MINI-r4wj-w4gq-4xjp, MINI-vm4w-cvq5-v5fg, MINI-whx9-733g-h46j, MINI-x6mj-c25f-rqjx, UBUNTU-CVE-2022-39201

## What is CVE-2022-39201?

CVE-2022-39201 is a medium-severity vulnerability in Grafana Grafana, published on 13 Oct 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Grafana is an open source observability and data visualization platform. Starting with version 5.0.0-beta1 and prior to versions 8.5.14 and 9.1.8, Grafana could leak the authentication cookie of users to plugins. The vulnerability impacts data source and plugin proxy endpoints under certain conditions. The destination plugin could receive a user's Grafana authentication cookie. Versions 9.1.8 and 8.5.14 contain a patch for this issue. There are no known workarounds.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-39201?

6 open source packages ship an affected version, including github.com/grafana/grafana and grafana. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grafana/grafana` | Go | From 5.0.0-beta1 | 8.5.14 |
| `github.com/grafana/grafana` | Go | From 5.0.0-beta1 | 8.5.14 |
| `github.com/grafana/grafana` | Go | From 5.0.0-beta1+incompatible | None |
| `github.com/grafana/grafana` | Go | From 9.0.0 | 9.1.8 |
| `github.com/grafana/grafana` | Go | From 9.0.0 | 9.1.8 |
| `grafana` | Bitnami | From 5.0.1 | 8.5.14, 9.1.8 |

Products: Grafana Grafana.

## How do I fix CVE-2022-39201?

Upgrade github.com/grafana/grafana to a fixed version for your release line: 8.5.14 or 9.1.8.

## Is CVE-2022-39201 being exploited?

There is no known exploitation of CVE-2022-39201 in the wild and no public exploit code.

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39201 and fix it if it is affected.

What it is: CVE-2022-39201 is a medium-severity vulnerability in Grafana Grafana, published on 13 Oct 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-39201 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grafana/grafana (Go): affected from 5.0.0-beta1; fixed in 8.5.14
- github.com/grafana/grafana (Go): affected from 5.0.0-beta1; fixed in 8.5.14
- github.com/grafana/grafana (Go): affected from 5.0.0-beta1+incompatible; no fix listed
- github.com/grafana/grafana (Go): affected from 9.0.0; fixed in 9.1.8
- github.com/grafana/grafana (Go): affected from 9.0.0; fixed in 9.1.8
- grafana (Bitnami): affected from 5.0.1; fixed in 8.5.14, 9.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39201/ (Markdown: https://insights.sbomify.com/CVE-2022-39201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39201
- OSV: https://osv.dev/vulnerability/CVE-2022-39201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39201/
Summaries are generated and may contain mistakes; the official description above is the record.
