# CVE-2022-39202: IRC mode parameter confusion in matrix-appservice-irc

> Incorrect parsing of IRC mode commands allows attackers to trick operators into granting unauthorized permissions to specific users.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-cq7q-5c67-w39w

## What is CVE-2022-39202?

CVE-2022-39202 is a medium-severity vulnerability in matrix-org matrix-appservice-irc, published on 13 Sep 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

matrix-appservice-irc is an open source Node.js IRC bridge for Matrix. The Internet Relay Chat (IRC) protocol allows you to specify multiple modes in a single mode command. Due to a bug in the underlying matrix-org/node-irc library, affected versions of matrix-appservice-irc perform parsing of such modes incorrectly, potentially resulting in the wrong user being given permissions. Mode commands can only be executed by privileged users, so this can only be abused if an operator is tricked into running the command on behalf of an attacker. The vulnerability has been patched in matrix-appservice-irc 0.35.0. As a workaround users should refrain from entering mode commands suggested by untrusted users. Avoid using multiple modes in a single command.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-39202?

2 open source packages ship an affected version, including matrix-appservice-irc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-appservice-irc` | npm | All versions | 0.35.0 |
| `matrix-appservice-irc` | npm | All versions | 0.35.0 |

Products: Matrix Matrix Irc Bridge.

## How do I fix CVE-2022-39202?

Upgrade matrix-appservice-irc to 0.35.0 or later.

## Is CVE-2022-39202 being exploited?

There is no known exploitation of CVE-2022-39202 in the wild and no public exploit code.

## Other vulnerabilities in matrix-org matrix-appservice-irc

- [CVE-2022-39203](https://insights.sbomify.com/CVE-2022-39203/): Parsing issue in matrix-org/node-irc leading to room takeovers (high 8.8)
- [CVE-2022-29166](https://insights.sbomify.com/CVE-2022-29166/): Improper handling of multiline messages in matrix-appservice-irc (high 8.0)
- [CVE-2023-38690](https://insights.sbomify.com/CVE-2023-38690/): matrix-appservice-irc IRC command injection via admin commands containing newlines (medium 5.8)
- [CVE-2022-3971](https://insights.sbomify.com/CVE-2022-3971/): matrix-appservice-irc PgDataStore.ts sql injection (medium 4.6)
- [CVE-2023-38700](https://insights.sbomify.com/CVE-2023-38700/): matrix-appservice-irc events can be crafted to leak parts of targeted messages from other bridged rooms (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39202 and fix it if it is affected.

What it is: CVE-2022-39202 is a medium-severity vulnerability in matrix-org matrix-appservice-irc, published on 13 Sep 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-39202 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-appservice-irc (npm): affected all versions; fixed in 0.35.0
- matrix-appservice-irc (npm): affected all versions; fixed in 0.35.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39202/ (Markdown: https://insights.sbomify.com/CVE-2022-39202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39202
- OSV: https://osv.dev/vulnerability/CVE-2022-39202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39202/
Summaries are generated and may contain mistakes; the official description above is the record.
