# CVE-2022-39206: CI/CD Docker Escape in OneDev

> Regular users can escape Docker containers to gain root privileges on the host by leveraging mounted Docker sockets in CI/CD jobs.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-gjq9-4xx9-cr3q

## What is CVE-2022-39206?

CVE-2022-39206 is a critical vulnerability in theonedev onedev, published on 13 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Onedev is an open source, self-hosted Git Server with CI/CD and Kanban. When using Docker-based job executors, the Docker socket (e.g. /var/run/docker.sock on Linux) is mounted into each Docker step. Users that can define and trigger CI/CD jobs on a project could use this to control the Docker daemon on the host machine. This is a known dangerous pattern, as it can be used to break out of Docker containers and, in most cases, gain root privileges on the host system. This issue allows regular (non-admin) users to potentially take over the build infrastructure of a OneDev instance. Attackers need to have an account (or be able to register one) and need permission to create a project. Since code.onedev.io has the right preconditions for this to be exploited by remote attackers, it could have been used to hijack builds of OneDev itself, e.g. by injecting malware into the docker images that are built and pushed to Docker Hub. The impact is increased by this as described before. Users are advised to upgrade to 7.3.0 or higher. There are no known workarounds for this issue.

Weakness: CWE-610 (Externally Controlled Reference to a Resource in Another Sphere)

## Which versions are affected by CVE-2022-39206?

It affects 1 product.


Products: Onedev Project Onedev.

## How do I fix CVE-2022-39206?

No fix has been published for CVE-2022-39206 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-39206 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39206 exists.

## Other vulnerabilities in theonedev onedev

- [CVE-2021-21242](https://insights.sbomify.com/CVE-2021-21242/): Pre-Auth Unsafe Deserialization on AttachmentUploadServet (critical 10.0)
- [CVE-2021-21243](https://insights.sbomify.com/CVE-2021-21243/): Pre-Auth Unsafe Deserialization on KubernetesResource (critical 10.0)
- [CVE-2021-21244](https://insights.sbomify.com/CVE-2021-21244/): Pre-Auth SSTI via Bean validation message tampering (critical 10.0)
- [CVE-2021-21245](https://insights.sbomify.com/CVE-2021-21245/): Pre-Auth Arbitrary File Upload (critical 10.0)
- [CVE-2021-21247](https://insights.sbomify.com/CVE-2021-21247/): Post-Auth Unsafe Deserialization on BasePage (AJAX) (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39206 and fix it if it is affected.

What it is: CVE-2022-39206 is a critical vulnerability in theonedev onedev, published on 13 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39206 exists.

Affected product: theonedev onedev. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39206/ (Markdown: https://insights.sbomify.com/CVE-2022-39206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39206
- OSV: https://osv.dev/vulnerability/CVE-2022-39206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39206/
Summaries are generated and may contain mistakes; the official description above is the record.
