{"answers":{"affected":"3 open source packages ship an affected version, including github.com/pandatix/go-cvss. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39213 exists.","fix":"Upgrade github.com/pandatix/go-cvss to 0.4.0 or later.","what":"CVE-2022-39213 is a high-severity denial of service vulnerability in pandatix go-cvss, published on 15 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39213 and fix it if it is affected.\n\nWhat it is: CVE-2022-39213 is a high-severity denial of service vulnerability in pandatix go-cvss, published on 15 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39213 exists.\n\nAffected packages and fixed versions:\n- github.com/pandatix/go-cvss (Go): affected from 0.2.0; fixed in 0.4.0\n- github.com/pandatix/go-cvss (Go): affected from 0.2.0; fixed in 0.4.0\n- github.com/pandatix/go-cvss (Go): affected from 0.2.0; fixed in 0.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39213/ (Markdown: https://insights.sbomify.com/CVE-2022-39213/index.md)","id":"CVE-2022-39213","markdown":"https://insights.sbomify.com/CVE-2022-39213/index.md","name":"CVE-2022-39213","record":{"aliases":["GHSA-xhmf-mmv2-4hhx","GO-2022-1002"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go CVSS library","requires_auth":"none","summary":"Attackers can cause a panic and denial of service in applications using the go-cvss library by providing specific CVSS v2.0 vector strings.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"go-cvss","vendor":"pandatix"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"go-cvss is a Go module to manipulate Common Vulnerability Scoring System (CVSS). In affected versions when a full CVSS v2.0 vector string is parsed using `ParseVector`, an Out-of-Bounds Read is possible due to a lack of tests. The Go module will then panic. The problem is patched in tag `v0.4.0`, by the commit `d9d478ff0c13b8b09ace030db9262f3c2fe031f4`. Users are advised to upgrade. Users unable to upgrade may avoid this issue by parsing only CVSS v2.0 vector strings that do not have all attributes defined (e.g. `AV:N/AC:L/Au:N/C:P/I:P/A:C/E:U/RL:OF/RC:C/CDP:MH/TD:H/CR:M/IR:M/AR:M`). As stated in [SECURITY.md](https://github.com/pandatix/go-cvss/blob/master/SECURITY.md), the CPE v2.3 to refer to this Go module is `cpe:2.3:a:pandatix:go_cvss:*:*:*:*:*:*:*:*`. The entry has already been requested to the NVD CPE dictionary.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Out-of-bounds Read in go-cvss","id":"CVE-2022-39213","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"Authenticated users of Combodo iTop can take over any account","id":"CVE-2022-39214"},"packages":[{"ecosystem":"Go","fixed":["0.4.0"],"introduced":["0.2.0"],"last_affected":[],"package":"github.com/pandatix/go-cvss","purl":null,"source":"GHSA-xhmf-mmv2-4hhx"},{"ecosystem":"Go","fixed":["0.4.0"],"introduced":["0.2.0"],"last_affected":[],"package":"github.com/pandatix/go-cvss","purl":"pkg:golang/github.com/pandatix/go-cvss","source":"GHSA-xhmf-mmv2-4hhx"},{"ecosystem":"Go","fixed":["0.4.0"],"introduced":["0.2.0"],"last_affected":[],"package":"github.com/pandatix/go-cvss","purl":"pkg:golang/github.com/pandatix/go-cvss","source":"GO-2022-1002"}],"prev":{"headline":"Last video frame is still sent after video is disabled in a call in Nextcloud Talk","id":"CVE-2022-39212"},"products":["go-cvss"],"published":"2022-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["pandatix"]},"summary":"Attackers can cause a panic and denial of service in applications using the go-cvss library by providing specific CVSS v2.0 vector strings.","url":"https://insights.sbomify.com/CVE-2022-39213/"}