# CVE-2022-39218: Random number seed fixed during compilation

> Predictable random number generation in Fastly's JS Compute Runtime allows attackers to bypass cryptographic controls and disclose sensitive data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-cmr8-5w4c-44v8

## What is CVE-2022-39218?

CVE-2022-39218 is a high-severity vulnerability in fastly js-compute-runtime, published on 20 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The JS Compute Runtime for Fastly's Compute@Edge platform provides the environment JavaScript is executed in when using the Compute@Edge JavaScript SDK. In versions prior to 0.5.3, the `Math.random` and `crypto.getRandomValues` methods fail to use sufficiently random values. The initial value to seed the PRNG (pseudorandom number generator) is baked-in to the final WebAssembly module, making the sequence of random values for that specific WebAssembly module predictable. An attacker can use the fixed seed to predict random numbers generated by these functions and bypass cryptographic security controls, for example to disclose sensitive data encrypted by functions that use these generators. The problem has been patched in version 0.5.3. No known workarounds exist.

Weakness: CWE-335 (Incorrect Usage of Seeds in Pseudo-Random Number Generator (PRNG))

## Which versions are affected by CVE-2022-39218?

2 open source packages ship an affected version, including @fastly/js-compute. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fastly/js-compute` | npm | From 0.4.0 | 0.5.3 |
| `@fastly/js-compute` | npm | From 0.4.0 | 0.5.3 |

Products: Fastly Js-Compute.

## How do I fix CVE-2022-39218?

Upgrade @fastly/js-compute to 0.5.3 or later.

## Is CVE-2022-39218 being exploited?

There is no known exploitation of CVE-2022-39218 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39218 and fix it if it is affected.

What it is: CVE-2022-39218 is a high-severity vulnerability in fastly js-compute-runtime, published on 20 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39218 in the wild and no public exploit code.

Affected packages and fixed versions:
- @fastly/js-compute (npm): affected from 0.4.0; fixed in 0.5.3
- @fastly/js-compute (npm): affected from 0.4.0; fixed in 0.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39218/ (Markdown: https://insights.sbomify.com/CVE-2022-39218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39218
- OSV: https://osv.dev/vulnerability/CVE-2022-39218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39218/
Summaries are generated and may contain mistakes; the official description above is the record.
