{"answers":{"affected":"2 open source packages ship an affected version, including github.com/dexidp/dex. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39222 exists.","fix":"Upgrade github.com/dexidp/dex to 2.35.0 or later.","what":"CVE-2022-39222 is a critical vulnerability in dexidp dex, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-39222 and fix it if it is affected.\n\nWhat it is: CVE-2022-39222 is a critical vulnerability in dexidp dex, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39222 exists.\n\nAffected packages and fixed versions:\n- github.com/dexidp/dex (Go): affected all versions; fixed in 2.35.0\n- github.com/dexidp/dex (Go): affected all versions; fixed in 2.35.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39222/ (Markdown: https://insights.sbomify.com/CVE-2022-39222/index.md)","id":"CVE-2022-39222","markdown":"https://insights.sbomify.com/CVE-2022-39222/index.md","name":"CVE-2022-39222","record":{"aliases":["GHSA-vh7g-p26c-j2cw"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"OIDC identity service","requires_auth":"none","summary":"Attackers can steal OAuth authorization codes from public clients via malicious websites, allowing them to gain unauthorized access to applications.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dex","vendor":"linuxfoundation"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Dex is an identity service that uses OpenID Connect to drive authentication for other apps. Dex instances with public clients (and by extension, clients accepting tokens issued by those Dex instances) are affected by this vulnerability if they are running a version prior to 2.35.0. An attacker can exploit this vulnerability by making a victim navigate to a malicious website and guiding them through the OIDC flow, stealing the OAuth authorization code in the process. The authorization code then can be exchanged by the attacker for a token, gaining access to applications accepting that token. Version 2.35.0 has introduced a fix for this issue. Users are advised to upgrade. There are no known workarounds for this issue.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"OAuth authorization code exposure in Dex","id":"CVE-2022-39222","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Arbitrary shell execution when extracting or listing files contained in a malicious rpm.","id":"CVE-2022-39224"},"packages":[{"ecosystem":"Go","fixed":["2.35.0"],"introduced":["0"],"last_affected":[],"package":"github.com/dexidp/dex","purl":null,"source":"GHSA-vh7g-p26c-j2cw"},{"ecosystem":"Go","fixed":["2.35.0"],"introduced":["0"],"last_affected":[],"package":"github.com/dexidp/dex","purl":"pkg:golang/github.com/dexidp/dex","source":"GHSA-vh7g-p26c-j2cw"}],"prev":{"headline":"Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') McWebserver Minecraft Mod","id":"CVE-2022-39221"},"products":["dex"],"published":"2022-10-06","related":[{"cvss_score":9.8,"headline":"Auth bypass in dexidp/dex","id":"CVE-2020-27847","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":9.3,"headline":"Critical security issues in XML encoding in Dex","id":"CVE-2020-26290","kev_date_added":null,"published":"2020-12-28"},{"cvss_score":7.5,"headline":"Dex 2.37.0 is discarding TLSconfig and always serves deprecated TLS 1.0/1.1 and insecure ciphers","id":"CVE-2024-23656","kev_date_added":null,"published":"2024-01-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["dexidp"]},"summary":"Attackers can steal OAuth authorization codes from public clients via malicious websites, allowing them to gain unauthorized access to applications.","url":"https://insights.sbomify.com/CVE-2022-39222/"}