# CVE-2022-39222: OAuth authorization code exposure in Dex

> Attackers can steal OAuth authorization codes from public clients via malicious websites, allowing them to gain unauthorized access to applications.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Oct 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-vh7g-p26c-j2cw

## What is CVE-2022-39222?

CVE-2022-39222 is a critical vulnerability in dexidp dex, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Dex is an identity service that uses OpenID Connect to drive authentication for other apps. Dex instances with public clients (and by extension, clients accepting tokens issued by those Dex instances) are affected by this vulnerability if they are running a version prior to 2.35.0. An attacker can exploit this vulnerability by making a victim navigate to a malicious website and guiding them through the OIDC flow, stealing the OAuth authorization code in the process. The authorization code then can be exchanged by the attacker for a token, gaining access to applications accepting that token. Version 2.35.0 has introduced a fix for this issue. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-862 (Missing Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-39222?

2 open source packages ship an affected version, including github.com/dexidp/dex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/dexidp/dex` | Go | All versions | 2.35.0 |
| `github.com/dexidp/dex` | Go | All versions | 2.35.0 |

Products: Linuxfoundation Dex.

## How do I fix CVE-2022-39222?

Upgrade github.com/dexidp/dex to 2.35.0 or later.

## Is CVE-2022-39222 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39222 exists.

## Other vulnerabilities in dexidp dex

- [CVE-2020-27847](https://insights.sbomify.com/CVE-2020-27847/): Auth bypass in dexidp/dex (critical 9.8)
- [CVE-2020-26290](https://insights.sbomify.com/CVE-2020-26290/): Critical security issues in XML encoding in Dex (critical 9.3)
- [CVE-2024-23656](https://insights.sbomify.com/CVE-2024-23656/): Dex 2.37.0 is discarding TLSconfig and always serves deprecated TLS 1.0/1.1 and insecure ciphers (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39222 and fix it if it is affected.

What it is: CVE-2022-39222 is a critical vulnerability in dexidp dex, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39222 exists.

Affected packages and fixed versions:
- github.com/dexidp/dex (Go): affected all versions; fixed in 2.35.0
- github.com/dexidp/dex (Go): affected all versions; fixed in 2.35.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39222/ (Markdown: https://insights.sbomify.com/CVE-2022-39222/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39222
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39222
- OSV: https://osv.dev/vulnerability/CVE-2022-39222

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39222/
Summaries are generated and may contain mistakes; the official description above is the record.
