{"answers":{"affected":"2 open source packages ship an affected version, including arr-pm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39224 exists.","fix":"Upgrade arr-pm to 0.0.12 or later.","what":"CVE-2022-39224 is a high-severity command injection vulnerability in jordansissel ruby-arr-pm, published on 21 Sep 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-39224 and fix it if it is affected.\n\nWhat it is: CVE-2022-39224 is a high-severity command injection vulnerability in jordansissel ruby-arr-pm, published on 21 Sep 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39224 exists.\n\nAffected packages and fixed versions:\n- arr-pm (RubyGems): affected all versions; fixed in 0.0.12\n- arr-pm (RubyGems): affected all versions; fixed in 0.0.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39224/ (Markdown: https://insights.sbomify.com/CVE-2022-39224/index.md)","id":"CVE-2022-39224","markdown":"https://insights.sbomify.com/CVE-2022-39224/index.md","name":"CVE-2022-39224","record":{"aliases":["GHSA-88cv-mj24-8w3q"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby RPM library","requires_auth":"none","summary":"Attackers can execute arbitrary shell commands via malicious RPM files processed by the arr-pm Ruby library.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ruby-arr-pm","vendor":"ruby-arr-pm_project"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Arr-pm is an RPM reader/writer library written in Ruby. Versions prior to 0.0.12 are subject to OS command injection resulting in shell execution if the RPM contains a malicious \"payload compressor\" field. This vulnerability impacts the `extract` and `files` methods of the `RPM::File` class of this library. Version 0.0.12 patches these issues. A workaround for this issue is to ensure any RPMs being processed contain valid/known payload compressor values such as gzip, bzip2, xz, zstd, and lzma. The payload compressor field in an rpm can be checked by using the rpm command line tool.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Arbitrary shell execution when extracting or listing files contained in a malicious rpm.","id":"CVE-2022-39224","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Parse Server subject to Incorrect Resource Transfer Between Spheres","id":"CVE-2022-39225"},"packages":[{"ecosystem":"RubyGems","fixed":["0.0.12"],"introduced":["0"],"last_affected":[],"package":"arr-pm","purl":null,"source":"GHSA-88cv-mj24-8w3q"},{"ecosystem":"RubyGems","fixed":["0.0.12"],"introduced":["0"],"last_affected":[],"package":"arr-pm","purl":"pkg:gem/arr-pm","source":"GHSA-88cv-mj24-8w3q"}],"prev":{"headline":"OAuth authorization code exposure in Dex","id":"CVE-2022-39222"},"products":["ruby-arr-pm"],"published":"2022-09-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["jordansissel"]},"summary":"Attackers can execute arbitrary shell commands via malicious RPM files processed by the arr-pm Ruby library.","url":"https://insights.sbomify.com/CVE-2022-39224/"}