# CVE-2022-39224: Arbitrary shell execution when extracting or listing files contained in a malicious rpm.

> Attackers can execute arbitrary shell commands via malicious RPM files processed by the arr-pm Ruby library.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-88cv-mj24-8w3q

## What is CVE-2022-39224?

CVE-2022-39224 is a high-severity command injection vulnerability in jordansissel ruby-arr-pm, published on 21 Sep 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Arr-pm is an RPM reader/writer library written in Ruby. Versions prior to 0.0.12 are subject to OS command injection resulting in shell execution if the RPM contains a malicious "payload compressor" field. This vulnerability impacts the `extract` and `files` methods of the `RPM::File` class of this library. Version 0.0.12 patches these issues. A workaround for this issue is to ensure any RPMs being processed contain valid/known payload compressor values such as gzip, bzip2, xz, zstd, and lzma. The payload compressor field in an rpm can be checked by using the rpm command line tool.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-39224?

2 open source packages ship an affected version, including arr-pm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `arr-pm` | RubyGems | All versions | 0.0.12 |
| `arr-pm` | RubyGems | All versions | 0.0.12 |

Products: Ruby-Arr-Pm Project Ruby-Arr-Pm.

## How do I fix CVE-2022-39224?

Upgrade arr-pm to 0.0.12 or later.

## Is CVE-2022-39224 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39224 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39224 and fix it if it is affected.

What it is: CVE-2022-39224 is a high-severity command injection vulnerability in jordansissel ruby-arr-pm, published on 21 Sep 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39224 exists.

Affected packages and fixed versions:
- arr-pm (RubyGems): affected all versions; fixed in 0.0.12
- arr-pm (RubyGems): affected all versions; fixed in 0.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39224/ (Markdown: https://insights.sbomify.com/CVE-2022-39224/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39224
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39224
- OSV: https://osv.dev/vulnerability/CVE-2022-39224

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39224/
Summaries are generated and may contain mistakes; the official description above is the record.
