# CVE-2022-39225: Parse Server subject to Incorrect Resource Transfer Between Spheres

> Attackers can read and modify other users' session objects if IDs are known, exposing custom fields and altering session ownership.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-parse-2022-39225, GHSA-6w4q-23cf-j9jp

## What is CVE-2022-39225?

CVE-2022-39225 is a medium-severity missing authorization vulnerability in Parseplatform Parse-Server, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 4.10.15, or 5.0.0 and above prior to 5.2.6, a user can write to the session object of another user if the session object ID is known. For example, an attacker can assign the session object to their own user by writing to the `user` field and then read any custom fields of that session object. Note that assigning a session to another user does not usually change the privileges of either of the two users, and a user cannot assign their own session to another user. This issue is patched in version 4.10.15 and above, and 5.2.6 and above. To mitigate this issue in unpatched versions add a `beforeSave` trigger to the `_Session` class and prevent writing if the requesting user is different from the user in the session object.

Weakness: CWE-669 (Incorrect Resource Transfer Between Spheres)

## Which versions are affected by CVE-2022-39225?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 4.10.15 |
| `parse-server` | npm | All versions | 4.10.15 |
| `parse-server` | npm | From 5.0.0 | 5.2.6 |
| `parse-server` | npm | From 5.0.0 | 5.2.6 |
| `parse` | Bitnami | All versions | 4.10.15, 5.2.6 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2022-39225?

Upgrade parse-server to a fixed version for your release line: 4.10.15 or 5.2.6.

## Is CVE-2022-39225 being exploited?

There is no known exploitation of CVE-2022-39225 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39225 and fix it if it is affected.

What it is: CVE-2022-39225 is a medium-severity missing authorization vulnerability in Parseplatform Parse-Server, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39225 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 4.10.15
- parse-server (npm): affected all versions; fixed in 4.10.15
- parse-server (npm): affected from 5.0.0; fixed in 5.2.6
- parse-server (npm): affected from 5.0.0; fixed in 5.2.6
- parse (Bitnami): affected all versions; fixed in 4.10.15, 5.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39225/ (Markdown: https://insights.sbomify.com/CVE-2022-39225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39225
- OSV: https://osv.dev/vulnerability/CVE-2022-39225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39225/
Summaries are generated and may contain mistakes; the official description above is the record.
