# CVE-2022-39226: Discourse user profile location and website fields were not sufficiently length-limited

> Attackers can cause denial of service by injecting large text payloads into user profile fields, affecting other users viewing the profile.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-discourse-2022-39226, GHSA-jw3q-xg5g-qjrw

## What is CVE-2022-39226?

CVE-2022-39226 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 29 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open source discussion platform. In versions prior to 2.8.9 on the `stable` branch and prior to 2.9.0.beta10 on the `beta` and `tests-passed` branches, a malicious actor can add large payloads of text into the Location and Website fields of a user profile, which causes issues for other users when loading that profile. A fix to limit the length of user input for these fields is included in version 2.8.9 on the `stable` branch and version 2.9.0.beta10 on the `beta` and `tests-passed` branches. There are no known workarounds.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-39226?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2.8.9 |

Products: Discourse Discourse.

## How do I fix CVE-2022-39226?

Upgrade discourse to 2.8.9 or later.

## Is CVE-2022-39226 being exploited?

There is no known exploitation of CVE-2022-39226 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39226 and fix it if it is affected.

What it is: CVE-2022-39226 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 29 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39226 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2.8.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39226/ (Markdown: https://insights.sbomify.com/CVE-2022-39226/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39226
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39226
- OSV: https://osv.dev/vulnerability/CVE-2022-39226

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39226/
Summaries are generated and may contain mistakes; the official description above is the record.
