# CVE-2022-39227: Python-jwt subject to Authentication Bypass by Spoofing

> Attackers can forge JWT contents to spoof identities, hijack sessions, or bypass authentication in applications using this library.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2022
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-11032, GHSA-5p8v-58qm-c7fp, PYSEC-2022-259

## What is CVE-2022-39227?

CVE-2022-39227 is a critical authentication bypass vulnerability in davedoesdev python-jwt, published on 23 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

python-jwt is a module for generating and verifying JSON Web Tokens. Versions prior to 3.3.4 are subject to Authentication Bypass by Spoofing, resulting in identity spoofing, session hijacking or authentication bypass. An attacker who obtains a JWT can arbitrarily forge its contents without knowing the secret key. Depending on the application, this may for example enable the attacker to spoof other user's identities, hijack their sessions, or bypass authentication. Users should upgrade to version 3.3.4. There are no known workarounds.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2022-39227?

3 open source packages ship an affected version, including python-jwt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-jwt` | PyPI | All versions | 3.3.4 |
| `python-jwt` | PyPI | All versions | 3.3.4 |
| `python-jwt` | PyPI | From 3.0.0 | 3.3.4 |

Products: Python-Jwt Project Python-Jwt.

## How do I fix CVE-2022-39227?

Upgrade python-jwt to 3.3.4 or later.

## Is CVE-2022-39227 being exploited?

There is no known exploitation of CVE-2022-39227 in the wild and no public exploit code.

Public exploit code:

- CVE-2022-39227 : Proof of Concept  (github_poc): https://github.com/user0x1337/CVE-2022-39227
- https://github.com/melikesraoz/cve-2022-39227-jwt-auth-bypass-demo (github_poc): https://github.com/melikesraoz/cve-2022-39227-jwt-auth-bypass-demo
- A working POC found while doing a HTB challenge. Original: https://github.com/user0x1337/CVE-2022-39227 (github_poc): https://github.com/NoSpaceAvailable/CVE-2022-39227

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39227 and fix it if it is affected.

What it is: CVE-2022-39227 is a critical authentication bypass vulnerability in davedoesdev python-jwt, published on 23 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39227 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-jwt (PyPI): affected all versions; fixed in 3.3.4
- python-jwt (PyPI): affected all versions; fixed in 3.3.4
- python-jwt (PyPI): affected from 3.0.0; fixed in 3.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39227/ (Markdown: https://insights.sbomify.com/CVE-2022-39227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39227
- OSV: https://osv.dev/vulnerability/CVE-2022-39227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39227/
Summaries are generated and may contain mistakes; the official description above is the record.
