# CVE-2022-39228: Observable Response Discrepancy in vantage6

> Attackers can enumerate valid usernames by observing response discrepancies and account lockout behavior in vantage6.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Mar 2023
- **Updated:** 7 Mar 2025
- **Also known as:** GHSA-36gx-9q6h-g429, PYSEC-2023-52

## What is CVE-2022-39228?

CVE-2022-39228 is a medium-severity vulnerability in vantage6, published on 1 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vantage6 is a privacy preserving federated learning infrastructure for secure insight exchange. vantage6 does not inform the user of wrong username/password combination if the username actually exists. This is an attempt to prevent bots from obtaining usernames. However, if a wrong password is entered a number of times, the user account is blocked temporarily. This issue has been fixed in version 3.8.0.

Weakness: CWE-204 (Observable Response Discrepancy), CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2022-39228?

3 open source packages ship an affected version, including vantage6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6` | PyPI | All versions | 3.8.0 |
| `vantage6` | PyPI | All versions | 3.8.0 |
| `vantage6` | PyPI | From 3.3.3 | 3.8.0 |

Products: Vantage6 Vantage6.

## How do I fix CVE-2022-39228?

Upgrade vantage6 to 3.8.0 or later.

## Is CVE-2022-39228 being exploited?

There is no known exploitation of CVE-2022-39228 in the wild and no public exploit code.

## Other vulnerabilities in vantage6

- [CVE-2024-21649](https://insights.sbomify.com/CVE-2024-21649/): Remote code execution (high 8.8)
- [CVE-2023-23929](https://insights.sbomify.com/CVE-2023-23929/): Refresh tokens do not expire in Vantage6 (high 8.8)
- [CVE-2023-47631](https://insights.sbomify.com/CVE-2023-47631/): vantage6 Node accepts non-whitelisted algorithms from malicious server (high 7.2)
- [CVE-2024-21653](https://insights.sbomify.com/CVE-2024-21653/): vantage6 insecure SSH configuration for node and server containers (medium 6.5)
- [CVE-2023-22738](https://insights.sbomify.com/CVE-2023-22738/): Improper Preservation of Permissions in vantage6 (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39228 and fix it if it is affected.

What it is: CVE-2022-39228 is a medium-severity vulnerability in vantage6, published on 1 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39228 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6 (PyPI): affected all versions; fixed in 3.8.0
- vantage6 (PyPI): affected all versions; fixed in 3.8.0
- vantage6 (PyPI): affected from 3.3.3; fixed in 3.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39228/ (Markdown: https://insights.sbomify.com/CVE-2022-39228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39228
- OSV: https://osv.dev/vulnerability/CVE-2022-39228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39228/
Summaries are generated and may contain mistakes; the official description above is the record.
