CVE-2022-39230 Security issue in fhir-works-on-aws-authz-smart
An attacker can retrieve more sensitive information than permitted by their OAuth scope in search-type requests, requiring an upgrade to the library.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-39230?
CVE-2022-39230 is a medium-severity vulnerability in awslabs fhir-works-on-aws-authz-smart, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
fhir-works-on-aws-authz-smart is an implementation of the authorization interface from the FHIR Works interface. Versions 3.1.1 and 3.1.2 are subject to Exposure of Sensitive Information to an Unauthorized Actor. This issue allows a client of the API to retrieve more information than the client’s OAuth scope permits when making “search-type” requests. This issue would not allow a client to retrieve information about individuals other than those the client was already authorized to access. Users of fhir-works-on-aws-authz-smart 3.1.1 or 3.1.2 should upgrade to version 3.1.3 or higher immediately. Versions 3.1.0 and below are unaffected. There is no workaround for this issue.
Weakness: CWE-200
Which versions are affected by CVE-2022-39230?
2 open source packages ship an affected version, including fhir-works-on-aws-authz-smart. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
fhir-works-on-aws-authz-smart npm | From 3.1.1 | 3.1.3 |
fhir-works-on-aws-authz-smart npm | From 3.1.1 | 3.1.3 |
Products include Amazon Fhir-Works-on-Aws-Authz-Smart.
How do I fix CVE-2022-39230?
Upgrade fhir-works-on-aws-authz-smart to 3.1.3 or later.
Is CVE-2022-39230 being exploited?
There is no known exploitation of CVE-2022-39230 in the wild and no public exploit code.
Sources
Also known as GHSA-vv7x-7w4m-q72f.