{"answers":{"affected":"2 open source packages ship an affected version, including fhir-works-on-aws-authz-smart. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-39230 in the wild and no public exploit code.","fix":"Upgrade fhir-works-on-aws-authz-smart to 3.1.3 or later.","what":"CVE-2022-39230 is a medium-severity vulnerability in awslabs fhir-works-on-aws-authz-smart, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39230 and fix it if it is affected.\n\nWhat it is: CVE-2022-39230 is a medium-severity vulnerability in awslabs fhir-works-on-aws-authz-smart, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-39230 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fhir-works-on-aws-authz-smart (npm): affected from 3.1.1; fixed in 3.1.3\n- fhir-works-on-aws-authz-smart (npm): affected from 3.1.1; fixed in 3.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39230/ (Markdown: https://insights.sbomify.com/CVE-2022-39230/index.md)","id":"CVE-2022-39230","markdown":"https://insights.sbomify.com/CVE-2022-39230/index.md","name":"CVE-2022-39230","record":{"aliases":["GHSA-vv7x-7w4m-q72f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS FHIR authorization library","requires_auth":"low_privilege","summary":"An attacker can retrieve more sensitive information than permitted by their OAuth scope in search-type requests, requiring an upgrade to the library.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fhir-works-on-aws-authz-smart","vendor":"amazon"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"fhir-works-on-aws-authz-smart is an implementation of the authorization interface from the FHIR Works interface. Versions 3.1.1 and 3.1.2 are subject to Exposure of Sensitive Information to an Unauthorized Actor. This issue allows a client of the API to retrieve more information than the client’s OAuth scope permits when making “search-type” requests. This issue would not allow a client to retrieve information about individuals other than those the client was already authorized to access. Users of fhir-works-on-aws-authz-smart 3.1.1 or 3.1.2 should upgrade to version 3.1.3 or higher immediately. Versions 3.1.0 and below are unaffected. There is no workaround for this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security issue in fhir-works-on-aws-authz-smart","id":"CVE-2022-39230","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Parse Server subject to Improper Authentication allowing Auth adapter app ID validation to be circumvented","id":"CVE-2022-39231"},"packages":[{"ecosystem":"npm","fixed":["3.1.3"],"introduced":["3.1.1"],"last_affected":[],"package":"fhir-works-on-aws-authz-smart","purl":null,"source":"GHSA-vv7x-7w4m-q72f"},{"ecosystem":"npm","fixed":["3.1.3"],"introduced":["3.1.1"],"last_affected":[],"package":"fhir-works-on-aws-authz-smart","purl":"pkg:npm/fhir-works-on-aws-authz-smart","source":"GHSA-vv7x-7w4m-q72f"}],"prev":{"headline":"Grafana users with email as a username can block other users from signing in","id":"CVE-2022-39229"},"products":["fhir-works-on-aws-authz-smart"],"published":"2022-09-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["awslabs"]},"summary":"An attacker can retrieve more sensitive information than permitted by their OAuth scope in search-type requests, requiring an upgrade to the library.","url":"https://insights.sbomify.com/CVE-2022-39230/"}