# CVE-2022-39230: Security issue in fhir-works-on-aws-authz-smart

> An attacker can retrieve more sensitive information than permitted by their OAuth scope in search-type requests, requiring an upgrade to the library.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-vv7x-7w4m-q72f

## What is CVE-2022-39230?

CVE-2022-39230 is a medium-severity vulnerability in awslabs fhir-works-on-aws-authz-smart, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

fhir-works-on-aws-authz-smart is an implementation of the authorization interface from the FHIR Works interface. Versions 3.1.1 and 3.1.2 are subject to Exposure of Sensitive Information to an Unauthorized Actor. This issue allows a client of the API to retrieve more information than the client’s OAuth scope permits when making “search-type” requests. This issue would not allow a client to retrieve information about individuals other than those the client was already authorized to access. Users of fhir-works-on-aws-authz-smart 3.1.1 or 3.1.2 should upgrade to version 3.1.3 or higher immediately. Versions 3.1.0 and below are unaffected. There is no workaround for this issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-39230?

2 open source packages ship an affected version, including fhir-works-on-aws-authz-smart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fhir-works-on-aws-authz-smart` | npm | From 3.1.1 | 3.1.3 |
| `fhir-works-on-aws-authz-smart` | npm | From 3.1.1 | 3.1.3 |

Products: Amazon Fhir-Works-on-Aws-Authz-Smart.

## How do I fix CVE-2022-39230?

Upgrade fhir-works-on-aws-authz-smart to 3.1.3 or later.

## Is CVE-2022-39230 being exploited?

There is no known exploitation of CVE-2022-39230 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39230 and fix it if it is affected.

What it is: CVE-2022-39230 is a medium-severity vulnerability in awslabs fhir-works-on-aws-authz-smart, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39230 in the wild and no public exploit code.

Affected packages and fixed versions:
- fhir-works-on-aws-authz-smart (npm): affected from 3.1.1; fixed in 3.1.3
- fhir-works-on-aws-authz-smart (npm): affected from 3.1.1; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39230/ (Markdown: https://insights.sbomify.com/CVE-2022-39230/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39230
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39230
- OSV: https://osv.dev/vulnerability/CVE-2022-39230

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39230/
Summaries are generated and may contain mistakes; the official description above is the record.
