CVE-2022-39231 Parse Server subject to Improper Authentication allowing Auth adapter app ID validation to be circumvented
Attackers can bypass Facebook or Spotify authentication validation in Parse Server if app IDs are misconfigured as strings, allowing unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-39231?
CVE-2022-39231 is a low-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 23 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 4.10.16, or from 5.0.0 to 5.2.6, validation of the authentication adapter app ID for _Facebook_ and _Spotify_ may be circumvented. Configurations which allow users to authenticate using the Parse Server authentication adapter where `appIds` is set as a string instead of an array of strings authenticate requests from an app with a different app ID than the one specified in the `appIds` configuration. For this vulnerability to be exploited, an attacker needs to be assigned an app ID by the authentication provider which is a sub-set of the server-side configured app ID. This issue is patched in versions 4.10.16 and 5.2.7. There are no known workarounds.
Weakness: CWE-287
Which versions are affected by CVE-2022-39231?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 4.10.16 |
parse-server npm | All versions | 4.10.16 |
parse-server npm | From 5.0.0 | 5.2.7 |
parse-server npm | From 5.0.0 | 5.2.7 |
parse Bitnami | All versions | 4.10.16, 5.2.7 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2022-39231?
Upgrade parse-server to a fixed version for your release line: 4.10.16 or 5.2.7.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2022-39231 being exploited?
There is no known exploitation of CVE-2022-39231 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2022-39231, GHSA-r657-33vp-gp22.