{"answers":{"affected":"5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-39231 in the wild and no public exploit code.","fix":"Upgrade parse-server to a fixed version for your release line: 4.10.16 or 5.2.7.","what":"CVE-2022-39231 is a low-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 23 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39231 and fix it if it is affected.\n\nWhat it is: CVE-2022-39231 is a low-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 23 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-39231 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse-server (npm): affected all versions; fixed in 4.10.16\n- parse-server (npm): affected all versions; fixed in 4.10.16\n- parse-server (npm): affected from 5.0.0; fixed in 5.2.7\n- parse-server (npm): affected from 5.0.0; fixed in 5.2.7\n- parse (Bitnami): affected all versions; fixed in 4.10.16, 5.2.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39231/ (Markdown: https://insights.sbomify.com/CVE-2022-39231/index.md)","id":"CVE-2022-39231","markdown":"https://insights.sbomify.com/CVE-2022-39231/index.md","name":"CVE-2022-39231","record":{"aliases":["BIT-parse-2022-39231","GHSA-r657-33vp-gp22"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Parse Server backend","requires_auth":"none","summary":"Attackers can bypass Facebook or Spotify authentication validation in Parse Server if app IDs are misconfigured as strings, allowing unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"parse-server","vendor":"parseplatform"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 4.10.16, or from 5.0.0 to 5.2.6, validation of the authentication adapter app ID for _Facebook_ and _Spotify_ may be circumvented. Configurations which allow users to authenticate using the Parse Server authentication adapter where `appIds` is set as a string instead of an array of strings authenticate requests from an app with a different app ID than the one specified in the `appIds` configuration. For this vulnerability to be exploited, an attacker needs to be assigned an app ID by the authentication provider which is a sub-set of the server-side configured app ID. This issue is patched in versions 4.10.16 and 5.2.7. There are no known workarounds.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Parse Server subject to Improper Authentication allowing Auth adapter app ID validation to be circumvented","id":"CVE-2022-39231","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"parseplatform:parse-server","products":["parseplatform:parse-server"],"type":"auth_bypass","year":"2022"},"n_packages":5,"n_references":1,"next":{"headline":"Discourse vulnerable to incomplete quote causing a topic to crash in the browser","id":"CVE-2022-39232"},"packages":[{"ecosystem":"Bitnami","fixed":["4.10.16","5.2.7"],"introduced":["0","5.0.0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2022-39231"},{"ecosystem":"npm","fixed":["4.10.16"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-r657-33vp-gp22"},{"ecosystem":"npm","fixed":["4.10.16"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-r657-33vp-gp22"},{"ecosystem":"npm","fixed":["5.2.7"],"introduced":["5.0.0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-r657-33vp-gp22"},{"ecosystem":"npm","fixed":["5.2.7"],"introduced":["5.0.0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-r657-33vp-gp22"}],"prev":{"headline":"Security issue in fhir-works-on-aws-authz-smart","id":"CVE-2022-39230"},"products":["parse-server"],"published":"2022-09-23","related":[{"cvss_score":10,"headline":"Parse Server role escalation and CLP bypass via direct `_Join` table write","id":"CVE-2026-30966","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":10,"headline":"Parse Server literalizeRegexPart SQL Injection","id":"CVE-2024-27298","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":10,"headline":"Command Injection in Parse server","id":"CVE-2022-24760","kev_date_added":null,"published":"2022-03-11"},{"cvss_score":9.9,"headline":"Parse Server session token exfiltration via `redirectClassNameForKey` query parameter","id":"CVE-2026-30965","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":9.8,"headline":"Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution","id":"CVE-2023-36475","kev_date_added":null,"published":"2023-06-28"},{"cvss_score":9.8,"headline":"Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser","id":"CVE-2022-39396","kev_date_added":null,"published":"2022-11-10"},{"cvss_score":9.3,"headline":"Parse Server: Account takeover via operator injection in authentication data identifier","id":"CVE-2026-32248","kev_date_added":null,"published":"2026-03-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["parse-community"]},"summary":"Attackers can bypass Facebook or Spotify authentication validation in Parse Server if app IDs are misconfigured as strings, allowing unauthorized access.","url":"https://insights.sbomify.com/CVE-2022-39231/"}