# CVE-2022-39231: Parse Server subject to Improper Authentication allowing Auth adapter app ID validation to be circumvented

> Attackers can bypass Facebook or Spotify authentication validation in Parse Server if app IDs are misconfigured as strings, allowing unauthorized access.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-parse-2022-39231, GHSA-r657-33vp-gp22

## What is CVE-2022-39231?

CVE-2022-39231 is a low-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 23 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 4.10.16, or from 5.0.0 to 5.2.6, validation of the authentication adapter app ID for _Facebook_ and _Spotify_ may be circumvented. Configurations which allow users to authenticate using the Parse Server authentication adapter where `appIds` is set as a string instead of an array of strings authenticate requests from an app with a different app ID than the one specified in the `appIds` configuration. For this vulnerability to be exploited, an attacker needs to be assigned an app ID by the authentication provider which is a sub-set of the server-side configured app ID. This issue is patched in versions 4.10.16 and 5.2.7. There are no known workarounds.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-39231?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 4.10.16 |
| `parse-server` | npm | All versions | 4.10.16 |
| `parse-server` | npm | From 5.0.0 | 5.2.7 |
| `parse-server` | npm | From 5.0.0 | 5.2.7 |
| `parse` | Bitnami | All versions | 4.10.16, 5.2.7 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2022-39231?

Upgrade parse-server to a fixed version for your release line: 4.10.16 or 5.2.7.

## Is CVE-2022-39231 being exploited?

There is no known exploitation of CVE-2022-39231 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39231 and fix it if it is affected.

What it is: CVE-2022-39231 is a low-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 23 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39231 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 4.10.16
- parse-server (npm): affected all versions; fixed in 4.10.16
- parse-server (npm): affected from 5.0.0; fixed in 5.2.7
- parse-server (npm): affected from 5.0.0; fixed in 5.2.7
- parse (Bitnami): affected all versions; fixed in 4.10.16, 5.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39231/ (Markdown: https://insights.sbomify.com/CVE-2022-39231/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39231
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39231
- OSV: https://osv.dev/vulnerability/CVE-2022-39231

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39231/
Summaries are generated and may contain mistakes; the official description above is the record.
