# CVE-2022-39236: Matrix Javascript SDK improper beacon events can cause availability issues

> Attackers can send malformed beacon events to disrupt the Matrix JavaScript SDK, causing data corruption or service unavailability for client applications.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** CLEANSTART-2024-EM09581, DEBIAN-CVE-2022-39236, GHSA-hvv8-5v86-r45x, UBUNTU-CVE-2022-39236

## What is CVE-2022-39236?

CVE-2022-39236 is a medium-severity denial of service vulnerability in matrix-org matrix-js-sdk, published on 28 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Matrix Javascript SDK is the Matrix Client-Server SDK for JavaScript. Starting with version 17.1.0-rc.1, improperly formed beacon events can disrupt or impede the matrix-js-sdk from functioning properly, potentially impacting the consumer's ability to process data safely. Note that the matrix-js-sdk can appear to be operating normally but be excluding or corrupting runtime data presented to the consumer. This is patched in matrix-js-sdk v19.7.0. Redacting applicable events, waiting for the sync processor to store data, and restarting the client are possible workarounds. Alternatively, redacting the applicable events and clearing all storage will fix the further perceived issues. Downgrading to an unaffected version, noting that such a version may be subject to other vulnerabilities, will additionally resolve the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-39236?

2 open source packages ship an affected version, including matrix-js-sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-js-sdk` | npm | From 17.1.0-rc.1 | 19.7.0 |
| `matrix-js-sdk` | npm | From 17.1.0-rc.1 | 19.7.0 |

Products: Matrix Javascript Sdk.

## How do I fix CVE-2022-39236?

Upgrade matrix-js-sdk to 19.7.0 or later.

## Is CVE-2022-39236 being exploited?

There is no known exploitation of CVE-2022-39236 in the wild and no public exploit code.

## Other vulnerabilities in matrix-org matrix-js-sdk

- [CVE-2022-39250](https://insights.sbomify.com/CVE-2022-39250/): Matrix JavaScript SDK vulnerable to key/device identifier confusion in SAS verification (high 8.6)
- [CVE-2022-39251](https://insights.sbomify.com/CVE-2022-39251/): Matrix Javascript SDK vulnerable to Olm/Megolm protocol confusion (high 8.6)
- [CVE-2022-36059](https://insights.sbomify.com/CVE-2022-36059/): Prototype pollution in matrix-js-sdk (high 8.2)
- [CVE-2023-28427](https://insights.sbomify.com/CVE-2023-28427/): Prototype pollution in matrix-js-sdk (high 8.2)
- [CVE-2022-39249](https://insights.sbomify.com/CVE-2022-39249/): Matrix Javascript SDK vulnerable to impersonation via forwarded Megolm sessions (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39236 and fix it if it is affected.

What it is: CVE-2022-39236 is a medium-severity denial of service vulnerability in matrix-org matrix-js-sdk, published on 28 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39236 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-js-sdk (npm): affected from 17.1.0-rc.1; fixed in 19.7.0
- matrix-js-sdk (npm): affected from 17.1.0-rc.1; fixed in 19.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39236/ (Markdown: https://insights.sbomify.com/CVE-2022-39236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39236
- OSV: https://osv.dev/vulnerability/CVE-2022-39236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39236/
Summaries are generated and may contain mistakes; the official description above is the record.
