# CVE-2022-39251: Matrix Javascript SDK vulnerable to Olm/Megolm protocol confusion

> Attackers can spoof messages and inject malicious key backups by exploiting protocol confusion in the Matrix JavaScript SDK.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** CLEANSTART-2024-VR88487, DEBIAN-CVE-2022-39251, GHSA-r48r-j8fx-mq2c, UBUNTU-CVE-2022-39251

## What is CVE-2022-39251?

CVE-2022-39251 is a high-severity vulnerability in matrix-org matrix-js-sdk, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Matrix Javascript SDK is the Matrix Client-Server SDK for JavaScript. Prior to version 19.7.0, an attacker cooperating with a malicious homeserver can construct messages that legitimately appear to have come from another person, without any indication such as a grey shield. Additionally, a sophisticated attacker cooperating with a malicious homeserver could employ this vulnerability to perform a targeted attack in order to send fake to-device messages appearing to originate from another user. This can allow, for example, to inject the key backup secret during a self-verification, to make a targeted device start using a malicious key backup spoofed by the homeserver. These attacks are possible due to a protocol confusion vulnerability that accepts to-device messages encrypted with Megolm instead of Olm. Starting with version 19.7.0, matrix-js-sdk has been modified to only accept Olm-encrypted to-device messages. Out of caution, several other checks have been audited or added. This attack requires coordination between a malicious home server and an attacker, so those who trust their home servers do not need a workaround.

Weakness: CWE-322 (Key Exchange without Entity Authentication), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-39251?

2 open source packages ship an affected version, including matrix-js-sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-js-sdk` | npm | All versions | 19.7.0 |
| `matrix-js-sdk` | npm | All versions | 19.7.0 |

Products: Matrix Javascript Sdk.

## How do I fix CVE-2022-39251?

Upgrade matrix-js-sdk to 19.7.0 or later.

## Is CVE-2022-39251 being exploited?

There is no known exploitation of CVE-2022-39251 in the wild and no public exploit code.

## Other vulnerabilities in matrix-org matrix-js-sdk

- [CVE-2022-39250](https://insights.sbomify.com/CVE-2022-39250/): Matrix JavaScript SDK vulnerable to key/device identifier confusion in SAS verification (high 8.6)
- [CVE-2022-36059](https://insights.sbomify.com/CVE-2022-36059/): Prototype pollution in matrix-js-sdk (high 8.2)
- [CVE-2023-28427](https://insights.sbomify.com/CVE-2023-28427/): Prototype pollution in matrix-js-sdk (high 8.2)
- [CVE-2022-39249](https://insights.sbomify.com/CVE-2022-39249/): Matrix Javascript SDK vulnerable to impersonation via forwarded Megolm sessions (high 7.5)
- [CVE-2021-40823](https://insights.sbomify.com/CVE-2021-40823/): matrix-js-sdk can be tricked into disclosing E2EE room keys to a participating homeserver (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39251 and fix it if it is affected.

What it is: CVE-2022-39251 is a high-severity vulnerability in matrix-org matrix-js-sdk, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39251 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-js-sdk (npm): affected all versions; fixed in 19.7.0
- matrix-js-sdk (npm): affected all versions; fixed in 19.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39251/ (Markdown: https://insights.sbomify.com/CVE-2022-39251/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39251
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39251
- OSV: https://osv.dev/vulnerability/CVE-2022-39251

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39251/
Summaries are generated and may contain mistakes; the official description above is the record.
