{"answers":{"affected":"2 open source packages ship an affected version, including io.github.skylot:jadx-plugins-api. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39259 exists.","fix":"Upgrade io.github.skylot:jadx-plugins-api to 1.4.5 or later.","what":"CVE-2022-39259 is a low-severity denial of service vulnerability in skylot jadx, published on 21 Oct 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-39259 and fix it if it is affected.\n\nWhat it is: CVE-2022-39259 is a low-severity denial of service vulnerability in skylot jadx, published on 21 Oct 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39259 exists.\n\nAffected packages and fixed versions:\n- io.github.skylot:jadx-plugins-api (Maven): affected all versions; fixed in 1.4.5\n- io.github.skylot:jadx-plugins-api (Maven): affected all versions; fixed in 1.4.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39259/ (Markdown: https://insights.sbomify.com/CVE-2022-39259/index.md)","id":"CVE-2022-39259","markdown":"https://insights.sbomify.com/CVE-2022-39259/index.md","name":"CVE-2022-39259","record":{"aliases":["GHSA-3r7j-8mqh-6qhx"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Android decompiler","requires_auth":"none","summary":"Attackers can cause a denial of service in Jadx-gui by tricking users into opening malicious zip files containing specific HTML sequences.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jadx","vendor":"jadx_project"}],"cvss":{"score":3.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"jadx is a set of command line and GUI tools for producing Java source code from Android Dex and Apk files. versions prior to 1.4.5 are subject to a Denial of Service when opening zip files with HTML sequences. This issue has been patched in version 1.4.5. There are no known workarounds.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Jadx-gui subject to Denial of Service via Swing HTML rendering","id":"CVE-2022-39259","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Git vulnerable to Remote Code Execution via Heap overflow in `git shell`","id":"CVE-2022-39260"},"packages":[{"ecosystem":"Maven","fixed":["1.4.5"],"introduced":["0"],"last_affected":[],"package":"io.github.skylot:jadx-plugins-api","purl":null,"source":"GHSA-3r7j-8mqh-6qhx"},{"ecosystem":"Maven","fixed":["1.4.5"],"introduced":["0"],"last_affected":[],"package":"io.github.skylot:jadx-plugins-api","purl":"pkg:maven/io.github.skylot/jadx-plugins-api","source":"GHSA-3r7j-8mqh-6qhx"}],"prev":{"headline":"mailcow-dockerized critical information misrepresentation can lead to phishing attacks through Swagger UI","id":"CVE-2022-39258"},"products":["jadx"],"published":"2022-10-21","related":[{"cvss_score":5.5,"headline":"Improper Restriction of XML External Entity Reference in skylot/jadx","id":"CVE-2022-0219","kev_date_added":null,"published":"2022-01-20"},{"cvss_score":3.6,"headline":"jadx: HTML Injection in Summary panel","id":"CVE-2026-42447","kev_date_added":null,"published":"2026-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["skylot"]},"summary":"Attackers can cause a denial of service in Jadx-gui by tricking users into opening malicious zip files containing specific HTML sequences.","url":"https://insights.sbomify.com/CVE-2022-39259/"}