# CVE-2022-39259: Jadx-gui subject to Denial of Service via Swing HTML rendering

> Attackers can cause a denial of service in Jadx-gui by tricking users into opening malicious zip files containing specific HTML sequences.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Oct 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-3r7j-8mqh-6qhx

## What is CVE-2022-39259?

CVE-2022-39259 is a low-severity denial of service vulnerability in skylot jadx, published on 21 Oct 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

jadx is a set of command line and GUI tools for producing Java source code from Android Dex and Apk files. versions prior to 1.4.5 are subject to a Denial of Service when opening zip files with HTML sequences. This issue has been patched in version 1.4.5. There are no known workarounds.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-39259?

2 open source packages ship an affected version, including io.github.skylot:jadx-plugins-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.github.skylot:jadx-plugins-api` | Maven | All versions | 1.4.5 |
| `io.github.skylot:jadx-plugins-api` | Maven | All versions | 1.4.5 |

Products: Jadx Project Jadx.

## How do I fix CVE-2022-39259?

Upgrade io.github.skylot:jadx-plugins-api to 1.4.5 or later.

## Is CVE-2022-39259 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39259 exists.

## Other vulnerabilities in skylot jadx

- [CVE-2022-0219](https://insights.sbomify.com/CVE-2022-0219/): Improper Restriction of XML External Entity Reference in skylot/jadx (medium 5.5)
- [CVE-2026-42447](https://insights.sbomify.com/CVE-2026-42447/): jadx: HTML Injection in Summary panel (low 3.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39259 and fix it if it is affected.

What it is: CVE-2022-39259 is a low-severity denial of service vulnerability in skylot jadx, published on 21 Oct 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39259 exists.

Affected packages and fixed versions:
- io.github.skylot:jadx-plugins-api (Maven): affected all versions; fixed in 1.4.5
- io.github.skylot:jadx-plugins-api (Maven): affected all versions; fixed in 1.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39259/ (Markdown: https://insights.sbomify.com/CVE-2022-39259/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39259
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39259
- OSV: https://osv.dev/vulnerability/CVE-2022-39259

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39259/
Summaries are generated and may contain mistakes; the official description above is the record.
