# CVE-2022-39260: Git vulnerable to Remote Code Execution via Heap overflow in `git shell`

> An integer overflow in git shell allows remote code execution if git shell is enabled as a login shell.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2022
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2022-39260, CLEANSTART-2026-BE06900, DEBIAN-CVE-2022-39260, GHSA-rjr6-wcq6-83p6, UBUNTU-CVE-2022-39260, USN-5686-2

## What is CVE-2022-39260?

CVE-2022-39260 is a high-severity vulnerability in Apple Xcode, published on 19 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Git is an open source, scalable, distributed revision control system. `git shell` is a restricted login shell that can be used to implement Git's push/pull functionality via SSH. In versions prior to 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4, the function that splits the command arguments into an array improperly uses an `int` to represent the number of entries in the array, allowing a malicious actor to intentionally overflow the return value, leading to arbitrary heap writes. Because the resulting array is then passed to `execv()`, it is possible to leverage this attack to gain remote code execution on a victim machine. Note that a victim must first allow access to `git shell` as a login shell in order to be vulnerable to this attack. This problem is patched in versions 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4 and users are advised to upgrade to the latest version. Disabling `git shell` access via remote logins is a viable short-term workaround.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2022-39260?

It affects 4 products.


Products: Apple Xcode, Debian Debian Linux, Fedoraproject Fedora, Git-Scm Git.

## How do I fix CVE-2022-39260?

Upgrade to a fixed version.

## Is CVE-2022-39260 being exploited?

There is no known exploitation of CVE-2022-39260 in the wild and no public exploit code.

## Other vulnerabilities in Apple Xcode

- [CVE-2025-48384](https://insights.sbomify.com/CVE-2025-48384/): Git Link Following (high 8.1, exploited in the wild)
- [CVE-2014-9390](https://insights.sbomify.com/CVE-2014-9390/): JGit Improper Input Validation vulnerability (critical 9.8)
- [CVE-2019-14379](https://insights.sbomify.com/CVE-2019-14379/): Deserialization of untrusted data in FasterXML jackson-databind (critical 9.8)
- [CVE-2018-4164](https://insights.sbomify.com/CVE-2018-4164/): An issue was discovered in certain Apple products. (critical 9.8)
- [CVE-2016-0746](https://insights.sbomify.com/CVE-2016-0746/): Use after free in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39260 and fix it if it is affected.

What it is: CVE-2022-39260 is a high-severity vulnerability in Apple Xcode, published on 19 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39260 in the wild and no public exploit code.

Affected product: Apple Xcode. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39260/ (Markdown: https://insights.sbomify.com/CVE-2022-39260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39260
- OSV: https://osv.dev/vulnerability/CVE-2022-39260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39260/
Summaries are generated and may contain mistakes; the official description above is the record.
