CVE-2022-39261 Twig may load a template outside a configured directory when using the filesystem loader
Attackers can read arbitrary files outside the template directory via crafted template names in Twig, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-39261?
CVE-2022-39261 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Twig is a template language for PHP. Versions 1.x prior to 1.44.7, 2.x prior to 2.15.3, and 3.x prior to 3.4.3 encounter an issue when the filesystem loader loads templates for which the name is a user input. It is possible to use the `source` or `include` statement to read arbitrary files from outside the templates' directory when using a namespace like `@somewhere/../some.file`. In such a case, validation is bypassed. Versions 1.44.7, 2.15.3, and 3.4.3 contain a fix for validation of such template names. There are no known workarounds aside from upgrading.
Weakness: CWE-22
Which versions are affected by CVE-2022-39261?
8 open source packages ship an affected version, including twig/twig, drupal and drupal/core. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
twig/twig Packagist | From 1.0.0 | 1.44.7 |
twig/twig Packagist | From 1.0.0 | 1.44.7 |
twig/twig Packagist | From 2.0.0 | 2.15.3 |
twig/twig Packagist | From 2.0.0 | 2.15.3 |
twig/twig Packagist | From 3.0.0 | 3.4.3 |
twig/twig Packagist | From 3.0.0 | 3.4.3 |
2 more packages
drupal Bitnami | From 8.0.0 | 9.3.22, 9.4.7 |
drupal/core Packagist | From 8.0.0 | 9.3.22, 9.4.7 |
Products include Debian Debian Linux, Drupal Drupal, Fedoraproject Fedora, Symfony Twig.
How do I fix CVE-2022-39261?
Upgrade twig/twig to a fixed version for your release line: 1.44.7, 2.15.3 or 3.4.3.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2022-39261 being exploited?
There is no known exploitation of CVE-2022-39261 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-drupal-2022-39261, DEBIAN-CVE-2022-39261, DLA-3147-1, DRUPAL-CORE-2022-016, DSA-5248-1, GHSA-52m2-vc4m-jj33 and 1 more.