# CVE-2022-39261: Twig may load a template outside a configured directory when using the filesystem loader

> Attackers can read arbitrary files outside the template directory via crafted template names in Twig, requiring an upgrade to fix.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-drupal-2022-39261, DEBIAN-CVE-2022-39261, DLA-3147-1, DRUPAL-CORE-2022-016, DSA-5248-1, GHSA-52m2-vc4m-jj33, UBUNTU-CVE-2022-39261

## What is CVE-2022-39261?

CVE-2022-39261 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Twig is a template language for PHP. Versions 1.x prior to 1.44.7, 2.x prior to 2.15.3, and 3.x prior to 3.4.3 encounter an issue when the filesystem loader loads templates for which the name is a user input. It is possible to use the `source` or `include` statement to read arbitrary files from outside the templates' directory when using a namespace like `@somewhere/../some.file`. In such a case, validation is bypassed. Versions 1.44.7, 2.15.3, and 3.4.3 contain a fix for validation of such template names. There are no known workarounds aside from upgrading.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-39261?

8 open source packages ship an affected version, including twig/twig, drupal and drupal/core. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twig/twig` | Packagist | From 1.0.0 | 1.44.7 |
| `twig/twig` | Packagist | From 1.0.0 | 1.44.7 |
| `twig/twig` | Packagist | From 2.0.0 | 2.15.3 |
| `twig/twig` | Packagist | From 2.0.0 | 2.15.3 |
| `twig/twig` | Packagist | From 3.0.0 | 3.4.3 |
| `twig/twig` | Packagist | From 3.0.0 | 3.4.3 |
| `drupal` | Bitnami | From 8.0.0 | 9.3.22, 9.4.7 |
| `drupal/core` | Packagist | From 8.0.0 | 9.3.22, 9.4.7 |

Products: Debian Debian Linux, Drupal Drupal, Fedoraproject Fedora, Symfony Twig.

## How do I fix CVE-2022-39261?

Upgrade twig/twig to a fixed version for your release line: 1.44.7, 2.15.3 or 3.4.3.

## Is CVE-2022-39261 being exploited?

There is no known exploitation of CVE-2022-39261 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39261 and fix it if it is affected.

What it is: CVE-2022-39261 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39261 in the wild and no public exploit code.

Affected packages and fixed versions:
- twig/twig (Packagist): affected from 1.0.0; fixed in 1.44.7
- twig/twig (Packagist): affected from 1.0.0; fixed in 1.44.7
- twig/twig (Packagist): affected from 2.0.0; fixed in 2.15.3
- twig/twig (Packagist): affected from 2.0.0; fixed in 2.15.3
- twig/twig (Packagist): affected from 3.0.0; fixed in 3.4.3
- twig/twig (Packagist): affected from 3.0.0; fixed in 3.4.3
- drupal (Bitnami): affected from 8.0.0; fixed in 9.3.22, 9.4.7
- drupal/core (Packagist): affected from 8.0.0; fixed in 9.3.22, 9.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39261/ (Markdown: https://insights.sbomify.com/CVE-2022-39261/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39261
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39261
- OSV: https://osv.dev/vulnerability/CVE-2022-39261

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39261/
Summaries are generated and may contain mistakes; the official description above is the record.
