{"answers":{"affected":"2 open source packages ship an affected version, including @next-auth/upstash-redis-adapter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-39263 in the wild and no public exploit code.","fix":"Upgrade @next-auth/upstash-redis-adapter to 3.0.2 or later.","what":"CVE-2022-39263 is a medium-severity authentication bypass vulnerability in nextauthjs next-auth, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-39263 and fix it if it is affected.\n\nWhat it is: CVE-2022-39263 is a medium-severity authentication bypass vulnerability in nextauthjs next-auth, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-39263 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @next-auth/upstash-redis-adapter (npm): affected all versions; fixed in 3.0.2\n- @next-auth/upstash-redis-adapter (npm): affected all versions; fixed in 3.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39263/ (Markdown: https://insights.sbomify.com/CVE-2022-39263/index.md)","id":"CVE-2022-39263","markdown":"https://insights.sbomify.com/CVE-2022-39263/index.md","name":"CVE-2022-39263","record":{"aliases":["GHSA-4rxr-27mm-mxq9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"NextAuth.js adapter","requires_auth":"none","summary":"Attackers can bypass email verification and sign in as victims by exploiting missing token checks in the Upstash Redis adapter.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"next-auth","vendor":"nextauth.js"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"`@next-auth/upstash-redis-adapter` is the Upstash Redis adapter for NextAuth.js, which provides authentication for Next.js. Applications that use `next-auth` Email Provider and `@next-auth/upstash-redis-adapter` before v3.0.2 are affected by this vulnerability. The Upstash Redis adapter implementation did not check for both the identifier (email) and the token, but only checking for the identifier when verifying the token in the email callback flow. An attacker who knows about the victim's email could easily sign in as the victim, given the attacker also knows about the verification token's expired duration. The vulnerability is patched in v3.0.2. A workaround is available. Using Advanced Initialization, developers can check the requests and compare the query's token and identifier before proceeding.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NextAuth.js Upstash Adapter missing token verification","id":"CVE-2022-39263","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"nheko vulnerable to secret poisoning using MITM on secret requests by the homeserver","id":"CVE-2022-39264"},"packages":[{"ecosystem":"npm","fixed":["3.0.2"],"introduced":["0"],"last_affected":[],"package":"@next-auth/upstash-redis-adapter","purl":null,"source":"GHSA-4rxr-27mm-mxq9"},{"ecosystem":"npm","fixed":["3.0.2"],"introduced":["0"],"last_affected":[],"package":"@next-auth/upstash-redis-adapter","purl":"pkg:npm/%40next-auth/upstash-redis-adapter","source":"GHSA-4rxr-27mm-mxq9"}],"prev":{"headline":"Stored Cross-Site Scripting (XSS) on login page in GLPI","id":"CVE-2022-39262"},"products":["next-auth"],"published":"2022-09-28","related":[{"cvss_score":9.1,"headline":"Verification requests (magic link) sent to unwanted emails","id":"CVE-2022-35924","kev_date_added":null,"published":"2022-08-02"},{"cvss_score":8.1,"headline":"Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth","id":"CVE-2023-27490","kev_date_added":null,"published":"2023-03-09"},{"cvss_score":7.5,"headline":"Improper Handling of `callbackUrl` parameter in next-auth","id":"CVE-2022-31093","kev_date_added":null,"published":"2022-06-27"},{"cvss_score":7.1,"headline":"Improper handling of email input in next-auth","id":"CVE-2022-31127","kev_date_added":null,"published":"2022-07-06"},{"cvss_score":6.1,"headline":"URL Redirection to Untrusted Site ('Open Redirect') in next-auth","id":"CVE-2022-29214","kev_date_added":null,"published":"2022-05-20"},{"cvss_score":6.1,"headline":"Default redirect callback vulnerable to open redirects","id":"CVE-2022-24858","kev_date_added":null,"published":"2022-04-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["nextauthjs"]},"summary":"Attackers can bypass email verification and sign in as victims by exploiting missing token checks in the Upstash Redis adapter.","url":"https://insights.sbomify.com/CVE-2022-39263/"}