# CVE-2022-39263: NextAuth.js Upstash Adapter missing token verification

> Attackers can bypass email verification and sign in as victims by exploiting missing token checks in the Upstash Redis adapter.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-4rxr-27mm-mxq9

## What is CVE-2022-39263?

CVE-2022-39263 is a medium-severity authentication bypass vulnerability in nextauthjs next-auth, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

`@next-auth/upstash-redis-adapter` is the Upstash Redis adapter for NextAuth.js, which provides authentication for Next.js. Applications that use `next-auth` Email Provider and `@next-auth/upstash-redis-adapter` before v3.0.2 are affected by this vulnerability. The Upstash Redis adapter implementation did not check for both the identifier (email) and the token, but only checking for the identifier when verifying the token in the email callback flow. An attacker who knows about the victim's email could easily sign in as the victim, given the attacker also knows about the verification token's expired duration. The vulnerability is patched in v3.0.2. A workaround is available. Using Advanced Initialization, developers can check the requests and compare the query's token and identifier before proceeding.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-39263?

2 open source packages ship an affected version, including @next-auth/upstash-redis-adapter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@next-auth/upstash-redis-adapter` | npm | All versions | 3.0.2 |
| `@next-auth/upstash-redis-adapter` | npm | All versions | 3.0.2 |

Products: Nextauth.js Next-Auth.

## How do I fix CVE-2022-39263?

Upgrade @next-auth/upstash-redis-adapter to 3.0.2 or later.

## Is CVE-2022-39263 being exploited?

There is no known exploitation of CVE-2022-39263 in the wild and no public exploit code.

## Other vulnerabilities in nextauthjs next-auth

- [CVE-2022-35924](https://insights.sbomify.com/CVE-2022-35924/): Verification requests (magic link) sent to unwanted emails (critical 9.1)
- [CVE-2023-27490](https://insights.sbomify.com/CVE-2023-27490/): Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth (high 8.1)
- [CVE-2022-31093](https://insights.sbomify.com/CVE-2022-31093/): Improper Handling of `callbackUrl` parameter in next-auth (high 7.5)
- [CVE-2022-31127](https://insights.sbomify.com/CVE-2022-31127/): Improper handling of email input in next-auth (high 7.1)
- [CVE-2022-29214](https://insights.sbomify.com/CVE-2022-29214/): URL Redirection to Untrusted Site ('Open Redirect') in next-auth (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39263 and fix it if it is affected.

What it is: CVE-2022-39263 is a medium-severity authentication bypass vulnerability in nextauthjs next-auth, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-39263 in the wild and no public exploit code.

Affected packages and fixed versions:
- @next-auth/upstash-redis-adapter (npm): affected all versions; fixed in 3.0.2
- @next-auth/upstash-redis-adapter (npm): affected all versions; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39263/ (Markdown: https://insights.sbomify.com/CVE-2022-39263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39263
- OSV: https://osv.dev/vulnerability/CVE-2022-39263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39263/
Summaries are generated and may contain mistakes; the official description above is the record.
