{"answers":{"affected":"1 open source package ship an affected version, including mybb. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39265 exists.","fix":"Upgrade mybb to 1.8.31 or later.","what":"CVE-2022-39265 is a high-severity command injection vulnerability in Mybb Mybb, published on 6 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39265 and fix it if it is affected.\n\nWhat it is: CVE-2022-39265 is a high-severity command injection vulnerability in Mybb Mybb, published on 6 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39265 exists.\n\nAffected packages and fixed versions:\n- mybb (Bitnami): affected all versions; fixed in 1.8.31\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39265/ (Markdown: https://insights.sbomify.com/CVE-2022-39265/index.md)","id":"CVE-2022-39265","markdown":"https://insights.sbomify.com/CVE-2022-39265/index.md","name":"CVE-2022-39265","record":{"aliases":["BIT-mybb-2022-39265","GHSA-hxhm-rq9f-7xj7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"MyBB forum software","requires_auth":"high_privilege","summary":"An admin with settings permissions can inject commands via mail parameters, leading to remote code execution and information disclosure.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mybb","vendor":"mybb"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"MyBB is a free and open source forum software. The _Mail Settings_ → Additional Parameters for PHP's mail() function mail_parameters setting value, in connection with the configured mail program's options and behavior, may allow access to sensitive information and Remote Code Execution (RCE). The vulnerable module requires Admin CP access with the `_Can manage settings?_` permission and may depend on configured file permissions. MyBB 1.8.31 resolves this issue with the commit `0cd318136a`. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Mail settings' command parameter injection in mybb","id":"CVE-2022-39265","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mybb:mybb","products":["mybb:mybb"],"type":"command_injection","year":"2022"},"n_packages":1,"n_references":4,"next":{"headline":"isolated-vm has vulnerable CachedDataOptions in API","id":"CVE-2022-39266"},"packages":[{"ecosystem":"Bitnami","fixed":["1.8.31"],"introduced":["0"],"last_affected":[],"package":"mybb","purl":"pkg:bitnami/mybb","source":"BIT-mybb-2022-39265"}],"prev":{"headline":"nheko vulnerable to secret poisoning using MITM on secret requests by the homeserver","id":"CVE-2022-39264"},"products":["mybb"],"published":"2022-10-06","related":[{"cvss_score":10,"headline":"myBB 1.6.4 Backdoor Arbitrary Command Execution","id":"CVE-2011-10018","kev_date_added":null,"published":"2025-08-13"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2015-2786","kev_date_added":null,"published":"2015-03-29"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2011-5133","kev_date_added":null,"published":"2012-08-30"},{"cvss_score":10,"headline":"SQL injection in n/a","id":"CVE-2006-0218","kev_date_added":null,"published":"2006-01-16"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2020-22612","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2017-16780","kev_date_added":null,"published":"2017-11-10"},{"cvss_score":8.8,"headline":"SQL injection in n/a","id":"CVE-2021-27890","kev_date_added":null,"published":"2021-03-15"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["mybb"]},"summary":"An admin with settings permissions can inject commands via mail parameters, leading to remote code execution and information disclosure.","url":"https://insights.sbomify.com/CVE-2022-39265/"}